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CAMERAS AND VIEWS
In the real world, you use a camera to both look at the world and record the
world. To look at the world from a camera’s point of view, you look into the
camera’s viewfinder. When you take a photograph, you are recording a 2D
image of the 3D world from the camera’s point of view onto film or
videotape.
There are two types of real-world cameras: still picture and motion picture.
Still picture cameras record a single image at a time. Motion picture cameras
record a continuous series of images (usually 24, 25, or 30 images per
second) that, when played back in sequence, create the illusion of motion.
In Maya, you use a camera to either look at a scene or render a scene, or both.
To look at a scene from a camera’s point of view, you look at the camera’s
view. When you render a scene, you are creating and recording a digital 2D
image of the 3D scene from a camera’s point of view onto your computer’s
disk.
View
A view represents the view from a
specific camera. You use views to look at
your scene as you create it. A scene can
contain several cameras, and therefore
several views. Objects in a view appear
as wireframe or shaded objects.
Rendered image
You render a scene by rendering a view
from a specific camera. Usually you use
several cameras to look at your scene
when you’re creating it, but only one
camera to render your scene when it’s
finished.
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There are two types of cameras in Maya: orthographic and perspective. Both
types of cameras can render either a single image or a continuous series of
images.
Perspective camera
Perspective cameras are similar to realworld cameras. They represent the effect
of perspective. When an object is near the
camera it appears larger than when it is
far from the camera. You use a
perspective camera to look at your scene
as you create it, and to render your scene
when it’s finished.
Orthographic camera
Orthographic cameras are not like realworld cameras. They do not represent
the effect of perspective. An object
viewed from an orthographic camera
appears to be the same size no matter
how near or far it is from the camera.
You use orthographic cameras to look at
your scene as you create it. (For
example, you can use an orthographic
camera to see the relative size of objects
or to align objects.) You do not usually
use orthographic cameras to render
your scene when it’s finished.
When you first start Maya, or create a new scene, by default the scene
contains four cameras (and views): three orthographic cameras (side, top,
and front) and one perspective camera (persp). You can, however, create
additional cameras.
This chapter contains the following sections:
•

“Creating cameras and views” on page 165

•

“Camera views and view guides” on page 167
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•

“Camera icons and manipulators” on page 170

•

“Setting up a camera” on page 173

•

“Setting a camera’s view” on page 176

•

“Saving and loading a camera’s view” on page 187

•

“Making camera views render faster” on page 189.

Creating cameras and views
When you first start Maya, or create a new scene, by default the scene
contains four cameras (and four views): three orthographic cameras (side,
top, and front) and one perspective camera (persp). You can, however, create
additional perspective and orthographic cameras (and views).
Usually, you use the four default cameras to view your scene, and create an
additional perspective camera to actually render from. If you render from
the default perspective camera, you may find it difficult to position the
camera without having another perspective camera to view your scene from,
especially if you are animating the camera.
You can create a camera from the main Maya window or from the view of
another camera. When you create a camera from the main Maya window, by
default, it is a perspective camera. In order to create an orthographic camera
from the main Maya window, you must set the Create Camera Options.
After you have created a camera, you can change whether it is a perspective
camera or an orthographic camera.
Note
If you are creating a camera that you plan to animate, see “Creating a
camera to animate” on page 166.
To create a camera (and view) from the main Maya window:
Select Create > Camera.
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Note
To set camera properties as you create the camera, select Create >
Camera ❐. See “Setting up a camera” on page 173.
To create a perspective camera (and view) from a view:
Select Panels > Perspective > New.
To create a perspective camera (and view) from Hypershade:
•

Select Create > Utilities > Camera.

•

Using the middle mouse button, drag the camera swatch from the Create >
Cameras folder in Visor into the Hypershade panel.
To create an orthographic camera (and view) from the main Maya
window:

1

Select Create > Camera ❐.

2

In the Orthographic Views section of the Create Camera Options window,
turn on Orthographic.

3

Click the Create button.
To create an orthographic camera (and view) from a view:
Select Panels > Orthographic > New.
To change a perspective camera to an orthographic camera (or vice
versa):

•

In the Orthographic Views section of the camera’s Attribute Editor, turn
Orthographic on or off.

•

In the camera’s view, select View > Camera Settings > Perspective.

Creating a camera to animate
When you create a camera, by default, it is a one-node camera. A one-node
camera has one node that controls its position and direction (the transform
node).
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A one-node camera is usually fine for rendering still images or for
animations in which the camera does not move or the camera’s motion is
very simple. However, you may find that a one-node camera is difficult to
animate for more complicated movements because you cannot easily control
the point that the camera looks at or the camera’s up direction.
To animate a one-node camera and control the point that the camera looks at
or the camera’s up direction, you need to use constraints. A constraint is a
way of controlling, or constraining, an object’s position, orientation, or scale
based on the position, orientation, or scale of another object. (For
information on using constraints, see “Constraints” in Using Maya: Character
Setup.) Instead of animating a one-node camera using constraints, you may
find it easier to animate a two-node or three-node camera.
A two-node camera has two nodes that control its position and direction,
and a three-node camera has three. These extra nodes allow you to easily
control the point that the camera looks at and the camera’s up direction, and
make animating the camera much easier.
Note
After you have created a camera, it is difficult to change whether it is a
one-node, two-node, or three-node camera.
To create a one-node, two-node, or three-node camera:
1

Select Create > Camera ❐.

2

In the Animation Options section of the Create Camera Options window,
select One, Two, or Three.

3

Click the Create button.

Camera views and view guides
When you first start Maya, or create a new scene, by default the scene
contains four cameras and four views. Camera views appear in panels in the
main Maya window.
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If you create a new camera, its view is not automatically displayed in a
panel. You can, however, control which views appear in which panels and
how panels are arranged in the Maya window. You can also display view
guides to help visualize how your scene will render.

Camera views
In the real world, you look at the world from a camera’s point of view by
looking into the camera’s viewfinder.
In Maya, you look at a scene from a camera’s point of view by displaying the
camera’s view, either in a panel or in a separate window.
To display a camera’s view in a panel:
•

From a view, select the camera’s name from the Panels > Perspective or
Panels > Orthographic sub-menu.

•

Select the camera, and from a view, select Panels > Look Through Selected.
For more information on arranging views, see “Arranging views” in Using
Maya: Basics.
To display a camera’s view in a window:
From a view, select Panel > Tear Off Copy.

Camera view guides
In the real world, the viewfinder of a camera may contain one or several
markings that help you determine what parts of the image will or will not be
recorded by the camera.
In Maya, a camera’s view may contain one or several view guides. By
default, a camera’s view does not display any view guides. Usually when
you are creating a scene, you do not need to display any view guides. You
can, however, display one or more of the several different types of view
guides to help you determine what parts of the scene will or will not render.
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No view guides
By default, a camera’s view does not
include any view guides.

Film gate
The Film Gate view guide indicates the
area of the camera’s view that a realworld camera would record on film. The
dimensions of the film gate represent the
dimensions of the camera aperture. The
film gate view guide indicates the area
of the camera’s view that will render
only if the aspect ratios of the camera
aperture and rendering resolution are
the same.
Resolution gate
The Resolution Gate view guide
indicates the area of the camera’s view
that will render. The dimensions of the
resolution gate represent the rendering
resolution. The rendering resolution
values are displayed above the
resolution gate view guide.
Field chart
The Field Chart view guide represents
the twelve standard cel animation field
sizes. The largest field size (number 12)
is identical to the rendering resolution
(the resolution gate).

CREATING A LOOK: LIGHTS, SURFACES, AND VIEWS

USING MAYA: RENDERING
169

CAMERAS AND VIEWS: 4
Camera icons and manipulators

Safe action
The Safe Action view guide indicates the
region that you should keep all of your
scene’s action within if you plan to
display the rendered images on a
television screen. The safe action view
guide represents 90% of the rendering
resolution (the resolution gate).
Safe title
The Safe Title view guide indicates the
region that you should keep titles (text)
within if you plan to display the
rendered images on a television screen.
The safe title view guide represents 80%
of the rendering resolution (the
resolution gate).
To display a camera view guide:
•

From the view panel, select the guide from the View > Camera Settings submenu.

•

Select the guide from the Display Options section of the camera’s Attribute
Editor.
Tip
To change the amount of space visible outside a view guide, in the Film
Back section of the camera’s Attribute Editor, adjust the Overscan
attribute.

Camera icons and manipulators
Usually you adjust a camera while looking through its view. However, you
can display camera icons and manipulators which allow you to visualize
and adjust a camera’s view without having to actually look through its view.
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Camera icons
A camera icon represents the position and direction of a camera in a view.
Camera icons are not visible by default.
Note
A camera’s icon is never visible in its own view. You can only see a
camera’s icon from another camera’s view.

Perspective Camera

Orthographic Camera

A circle on a two-node or three-node camera icon represents the view point
(center of interest), and a circle on a three-node camera represents the
camera’s up direction. See “Creating a camera to animate” on page 166.
Up Direction Point

Center of
Interest
Two-Node Camera

Center of
Interest
Three-Node Camera

To display all camera icons:
Select Display > Show > Cameras.
To hide all camera icons:
Select Display > Hide > Cameras.

CREATING A LOOK: LIGHTS, SURFACES, AND VIEWS

USING MAYA: RENDERING
171

CAMERAS AND VIEWS: 4
Camera icons and manipulators
To hide or display all camera icons in a specific view:
In a view, select Show > Cameras.

Camera manipulators
Camera manipulators allow you to interactively adjust certain camera
attributes.
Cycling index

Cycling Index

Click the Cycling Index manipulator to
display each of the camera’s three types
of manipulators: Center of Interest,
Pivot, and Clipping Planes. The position
of the dash on the Cycling Index
indicates which manipulator is
displayed.
Center of interest
Move the two parts of the Center of
Interest manipulator to change the
camera’s location (the manipulator on
the camera icon) and direction (the
manipulator on the circle). See “Setting a
camera’s center of interest” on page 178.

Pivot

Pivot
Move the Pivot manipulator and then
click on it to change the point that the
camera pivots about when you move the
camera or the center of interest. Click the
Pivot manipulator again to disable the
pivot point.
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Clipping planes
Move the two parts of the Clipping
Planes manipulator to change the
location of the near and far clipping
planes. See “Setting a camera’s range”
on page 184.

To display camera manipulators:
•

Select Display > Show > Camera Manipulators.

•

Click the Show Manipulator Tool (or press the hotkey t).

To display or hide a specific camera manipulator:
Select a camera and then select the manipulator from the Display > Camera/
Light Manipulator sub-menu.
To hide camera manipulators:
Select Display > Hide > Camera Manipulators.
To increase or decrease the size of camera manipulators:
Press - (decrease) or = (increase).

Setting up a camera
In the real world, every camera has certain basic physical characteristics that
do not change (for example, the camera’s film format: 16mm, 35mm, 70mm).
You select a specific camera for its basic physical characteristics based on
how you plan to use the film or video in post-production and how you plan
to present the finished film or video.
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In Maya, you can change all characteristics for a camera at any time.
However, you usually set a camera’s basic characteristics when you first
create it. You set these characteristics based on how you plan to use the
rendered images in post-production and how you plan to present the
finished film or video.
For example, if you plan to render a scene and then combine it with live
action, you will need to set up Maya’s camera to match the real-world
camera used to record the live action.
To set up a camera:
1

In the Film Back section of the camera’s Attribute Editor (View > Camera
Attribute Editor), select a preset Film Gate (for example, Super 16mm).
Maya automatically sets the following camera attributes. If you do not see an
appropriate preset Film Gate, you must set these attributes manually.
Camera Aperture

The height and width of the camera’s aperture or
film back, measured in inches. The Camera
Aperture controls the relationship between Focal
Length and Angle of View.

Film Aspect Ratio

The ratio of the camera aperture’s width to its
height. When you set the Camera Aperture values,
Maya automatically updates the Film Aspect Ratio
(and vice versa).

Lens Squeeze Ratio

The amount that the camera’s lens compresses the
image horizontally. Most cameras do not compress
the image they record, and their Lens Squeeze
Ratio is 1. Some cameras (for example, anamorphic
cameras), however, compress the image
horizontally in order to record a large aspect ratio
(wide) image onto a square area on film.

Tip
Turn on the Film Gate view guide in the Display Options section of the
camera’s Attribute Editor. See “Camera view guides” on page 168.
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The Film Gate represents the region of your scene that a real-world camera
would record. It does not usually represent the region of your scene that the
Maya camera will render.
2

In the Resolution section of the Render Globals window (Window > Render
Globals), select a preset Render Resolution (for example, 640 x 480).
Maya automatically sets the following attributes. If you do not see an
appropriate preset Render Resolution, you must set these attributes
manually.
Width, Height

The width and height of the image you want to
render, measured in pixels. The ratio of the width
and height is the image aspect ratio. When you set
the Width, Maya automatically updates the Height
(and vice versa) if Maintain Width/Height Ratio is
on. When you set the Width or Height, Maya
automatically updates the Device Aspect Ratio (if
Lock Device Aspect Ratio is off) or the Pixel Aspect
Ratio (if Lock Device Aspect Ratio is on).

Device Aspect Ratio

The aspect ratio of the display device you will be
viewing the rendered image on. The device aspect
ratio represents the image aspect ratio (see above)
multiplied by the pixel aspect ratio (see below).
Device Aspect Ratio and Pixel Aspect Ratio are
related; when you set the Device Aspect Ratio,
Maya automatically updates the Pixel Aspect
Ratio.

Pixel Aspect Ratio

The aspect ratio of the individual pixels of the
display device you will be viewing the rendered
image on. Most display devices (for example, a
computer monitor) have square pixels, and their
Pixel Aspect Ratio is 1. Some devices, however,
have non-square pixels (for example, digital video
has a Pixel Aspect Ratio of 0.9). Pixel Aspect Ratio
and Device Aspect Ratio are related; when you set
the Pixel Aspect Ratio, Maya automatically
updates the Device Aspect Ratio.
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Tip
Turn on the Resolution Gate view guide in the Display Options section of
the camera’s Attribute Editor. See “Camera view guides” on page 168.
The Render Resolution, or Resolution Gate, represents the region of your
scene that the camera will actually render.
3

Set the following camera attributes.
Film Fit

Controls the size of the resolution gate relative to
the film gate, and whether the resolution gate fits
within the film gate (Fill), fits only horizontally
(Horizontal) or vertically (Vertical) within the film
gate, or whether the film gate fits within the
resolution gate (Overscan).

Film Fit Offset

Offsets the resolution gate relative to the film gate,
either vertically (if Film Fit is Horizontal) or
horizontally (if Film Fit is Vertical). You usually
leave the Film Fit Offset as 0.

Film Offset

Vertically and horizontally offsets the resolution
gate and the film gate relative to the scene. You
usually leave both Film Offset values as 0.
However, you can track the view in two
dimensions using the Film Offset. See “Tracking a
camera’s view in two dimensions” on page 180.

Setting a camera’s view
In the real world, you set a camera’s view by first selecting a subject or center
of interest and then selecting how the camera will view the center of interest.
You can also selectively focus a camera so that certain objects are in sharp
focus while other objects are not.
In Maya, you set a camera’s view in the same way. You can also limit a
camera’s range so that only objects within this range are visible.
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Tip
Turn on the Resolution Gate view guide to see the area of your scene that
will actually render. See “Camera view guides” on page 168.

Note
By default, you cannot undo or redo all camera movements. To be able to
undo or redo all camera movements, turn on Journal Command in the
Display Options section of the camera’s Attribute Editor, or in the
camera’s view select View > Camera Settings > Journal.

Center of interest
The point in 3D space that the camera
looks at. An object that is located at this
point appears in the center of the
camera’s view. See “Setting a camera’s
center of interest” on page 178.
How a camera views its center of
interest
The distance and direction from which
the camera views the center of interest.
See “Setting how a camera views its
center of interest” on page 181.
Camera range
The range of distances from the camera
within which objects are visible. See
“Setting a camera’s range” on page 184.
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Selective focus
The distance or range of distances
within which objects appear sharply
focused and outside of which objects
appear blurred or out of focus. See
“Selectively focusing a camera’s view”
on page 185.

Setting a camera’s center of interest
A camera’s center of interest is the point in 3D space that the camera looks
at. An object that is located at this point appears in the center of the camera’s
view. You can set a camera’s center of interest in several ways.
Looking at objects or regions in a
scene
Tracks, tilts/pans, and/or dollies the
camera so that selected objects, all
objects, or a selected region are in the
camera’s view. See “Looking at objects
or regions in a scene” on page 179.
Tracking
Moves the camera left, right, up, or
down. The scene in the camera’s view
moves in the opposite direction. See
“Tracking a camera’s view” on page 179.
2D tracking
Moves the camera’s film back; the
camera does not move. The scene in the
camera’s view moves in the opposite
direction. Perspective, or the relative
orientation of objects in the scene, does
not change. See “Tracking a camera’s
view in two dimensions” on page 180.
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Tilting and panning
Tilts the camera up or down, or pans the
camera left or right. The scene in the
camera’s view moves in the opposite
direction. See “Tilting or panning a
camera’s view” on page 180.

Looking at objects or regions in a scene
You can easily set a camera’s center of interest to the center of a specific
object, group of objects, or region.
To look at selected objects:
Select View > Look At Selection.
The camera tilts and pans so that selected objects are in the center of the
camera’s view.
To look at and fill the view with selected objects:
Select View > Frame Selection (or press the hotkey f).
The camera tracks and dollies so that selected objects fill the camera’s view.
To look at and fill the view with all objects in a scene:
Select View > Frame All (or press the hotkey a).
The camera tracks and dollies so that all objects in the scene (including lights
and cameras if their icons are displayed in the view) fill the camera’s view.
To look at and fill the view with a region of a scene:
Ctrl-Alt-drag over the region.
The camera tracks and dollies so that the selected region fills the camera’s
view.

Tracking a camera’s view
Tracking a camera means moving the camera left, right, up, or down. The
scene in the camera’s view moves in the opposite direction.
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To track a camera’s view:
•

Using the middle mouse button, Alt-drag in the camera’s view. (The speed
that Maya tracks the camera is based on the distance from the camera to the
center of interest. If this distance is very small, the camera will track very
slowly.)

•

Select View > Camera Tools > Track Tool and drag in the camera’s view.

•

Select the Move tool (or press the hotkey w) and move the camera’s icon.

•

Select View > Frame Selection to track and dolly so that selected objects fill
the camera’s view.

•

Select View > Frame All to track and dolly so that all objects in the scene fill
the camera’s view.

Tracking a camera’s view in two dimensions
Tracking a camera in two dimensions means moving the camera’s film back,
not the camera itself. The scene in the camera’s view moves in the opposite
direction. The relative orientation of objects in the scene does not change.
To track a camera’s view in two dimensions:
Adjust the camera’s Film Offset values.

Tilting or panning a camera’s view
Tilting a camera means rotating the camera up or down; panning a camera
means rotating the camera left or right. The scene in the camera’s view
moves in the opposite direction. (The angle of rotation up or down is also
referred to as pitch; the angle of rotation left or right is also referred to as
yaw.)
To tilt or pan a camera’s view:
•

Select View > Camera Tools > Yaw-Pitch Tool and drag in the camera’s
view.

•

Select View > Look At Selection to tilt or pan the camera so that selected
objects are in the center of the camera’s view.

•

Move the camera’s Center of Interest manipulator.
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Setting how a camera views its center of interest
Once you set a camera’s center of interest, you set how the camera looks at its
center of interest. A camera can look at its center of interest from any
direction or distance.
Note
The Film Gate, Camera Aperture, Film Aspect Ratio, Lens Squeeze Ratio,
Film Fit, Film Fit Offset, and Film Offset attributes also affect a camera’s
view; however, you should set these attributes only when you are first
setting up a camera. See “Setting up a camera” on page 173.
There are several ways you can set how a camera views its center of interest.
Tumbling
Changes the position from which the
camera views its center of interest. The
scene in the camera’s view appears to
rotate about the center of interest. See
“Tumbling a camera’s view” on page
182.
Rolling
Rotates the camera about its sight line.
The camera’s view rotates in the
opposite direction. See “Rolling a
camera’s view” on page 182.
Dollying
Moves the camera toward or away from
its center of interest. The scene in the
camera’s view becomes larger or
smaller. The relative size of objects in the
scene changes based on their distance
from the camera. See “Dollying a
camera’s view” on page 183.
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Zooming
Changes the lens’s focal length; the
camera does not move. The scene in the
camera’s view becomes larger or
smaller. The relative size of objects in the
scene does not change. See “Zooming a
camera’s view” on page 183.

Tumbling a camera’s view
Tumbling a camera means changing the position from which the camera
views its center of interest. The scene in the camera’s view appears to rotate
about the center of interest. (The angle of a camera’s sight line relative to the
ground plane is also referred to as its elevation; the angle of a camera’s sight
line relative to a plane perpendicular to the ground plane is also referred to
as its azimuth.)
To tumble a camera’s view:
•

Alt-drag in the camera’s view.

•

Select View > Camera Tools > Tumble Tool and drag in the camera’s view.

•

Select View > Camera Tools > Azimuth Elevation Tool and drag in the
camera’s view.

•

Move the camera icon manipulator.

Rolling a camera’s view
Rolling a camera means rotating the camera about its sight line (the line
connecting the camera to its center of interest).
To roll a camera:
•

Select View > Camera Tools > Roll Tool and drag left or right in the camera’s
view.

•

Select the Rotate tool (or press the hotkey e) and rotate the camera’s icon
using the blue rotate manipulator.
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Dollying a camera’s view
Dollying a camera means moving the camera toward or away from its center
of interest. The scene in the camera’s view becomes larger or smaller. The
relative size of objects in the scene changes based on their distance from the
camera.
Note
When you dolly an orthographic camera, the camera does not actually
move. Instead, the camera’s viewing plane increases or decreases in size.
The effect in the camera’s view, however, is the same as moving the
camera.
To dolly a camera:
•

Using the left and middle mouse buttons, Alt-drag in the camera’s view.

•

Select View > Camera Tools > Dolly Tool and drag in the camera’s view.

•

Select View > Frame Selection to track and dolly so that selected objects fill
the camera’s view.

•

Select View > Frame All to track and dolly so that all objects in the scene fill
the camera’s view.

Zooming a camera’s view
Zooming a camera means changing the lens’s focal length; the camera does
not move. The scene in the camera’s view becomes larger or smaller. The
relative size of objects in the scene does not change.
To zoom a camera:
•

Select View > Camera Tools > Zoom Tool and drag in the camera’s view.

•

Adjust the camera’s Angle of View attribute or Focal Length attribute.
Note
The Camera Scale attribute also affects the amount of zoom.
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Setting a camera’s range
In the real-world, cameras can see objects no matter how near or far they are
from the camera’s lens.
In Maya, cameras can only see objects within a finite range of distances from
the camera. A camera’s range is represented by its clipping planes. All
cameras have a near clipping plane and a far clipping plane.
The near and far clipping planes are imaginary planes located at two specific
points along a camera’s sight line. Only objects between a camera’s two
clipping planes are visible in that camera’s view. Any objects in your scene
that are closer to the camera than the near clipping plane, or farther from the
camera than the far clipping plane, will not be visible.
Note
If part of an object is in front of the near clipping plane, then only the part
of the object beyond the near clipping plane will be visible. If part of an
object is beyond the far clipping plane, then the entire object will be
visible, including the part beyond the far clipping plane.
By default, Maya automatically sets a camera’s clipping planes so that they
are just slightly beyond the limits of the objects in your scene. However, you
can also manually set a camera’s clipping planes to limit which objects are
visible in the camera’s view (see “Selecting a range of objects and shadows
to render” on page 227).
Tip
Turn on the camera’s Clipping Planes manipulator (see “Camera
manipulators” on page 172). The dimensions of the Clipping Planes
manipulator represents the camera’s film gate, not the rendering
resolution, and may or may not indicate the region that will actually
render. See “Film gate” on page 169.

Note
The camera’s view only displays objects between the near and far
clipping planes.
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To set clipping planes automatically:
Turn on the camera’s Auto Render Clip Plane attribute.
To set clipping planes manually:
1

Turn off the camera’s Auto Render Clip Plane attribute.

2

Set the camera’s Near Clip Plane attribute to the distance from the camera to
the near clipping plane.

3

Set the camera’s Far Clip Plane attribute to the distance from the camera to
the far clipping plane.
Note
If the distance between the near and far clipping planes is much larger
than is required to contain all the objects in your scene, the image quality
of some objects may be poor. Set the Near Clip Plane attribute to the
largest value and the Far Clip Plane attribute to the lowest value that still
produces the desired result.

Note
If you set a camera’s clipping planes manually so that a shadow-casting
surface is beyond the far clipping plane, and a depth-map shadowcasting light is illuminating the surface, the surface will not render, but
the surface’s shadow will render. To remove the shadow, turn off Casts
Shadows for the surface.

Selectively focusing a camera’s view
In the real world, a camera has a range of distances within which objects will
be sharply focused. This range of distances is known as the camera’s depth of
field. Objects that are outside of this range (closer to the camera or farther
away from the camera) appear blurred or out of focus.
In Maya, by default all objects are sharply focused no matter now near or far
they are from the camera. You can, however, selectively focus a camera to
simulate depth of field.
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Note
When you render a scene from a camera that uses depth of field, the
entire scene will first render with all objects in sharp focus. Different
objects in the image will then be blurred based on their distance from the
camera.
To selectively focus a camera’s view:
In the Depth of Field section of the camera’s Attribute Editor, turn on Depth
Of Field.

Properties of selective focus
You can change the properties of a camera’s depth of field to control which
objects are in sharp focus, and which objects are not.
Focus distance
To change the distance from the camera
at which objects appear in sharp focus,
adjust the Focus Distance attribute. To
scale the Focus Distance attribute, adjust
the Focus Region Scale attribute.
Focus range
To change the range of distances from
the camera within which objects appear
in sharp focus, adjust the F Stop
attribute. (The smaller the F Stop, the
shorter the depth of field.)
The Focal Length and Angle of View
attributes also influence the range of
distances from the camera within which
objects appear in sharp focus.
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Tip
To make the camera automatically focus on its center of interest (similar
to a real-world camera’s auto-focus function), connect the output of the
camera group node’s Distance Between attribute to the input of the
camera shape node’s Focus Distance attribute. This is only possible with
two-node and three-node cameras because one-node cameras do not have
a camera group node (see “Creating a camera to animate” on page 166
and “Connecting nodes” on page 18).

Note
Changing your scene’s linear working unit will alter a camera’s depth of
field. Use the Focus Region Scale attribute to compensate for any changes
you make to your scene’s linear working unit if you want to maintain the
same depth of field. For example, if you change your scene’s linear
working unit from centimeters to meters, change the Focus Region Scale
value from 1 to 100. The Focus Region Scale attribute can also make
controlling a camera’s depth of field easier over very long distances (for
example, stars and planets) or very short distances (for example,
microscopic close-ups).

Saving and loading a camera’s view
Once you have set a camera’s view, you may want to save it. After you save
a camera’s view, you can adjust the view and later easily load the saved
view.
You save a camera’s view by creating a bookmark. By default, a camera has
four pre-defined bookmarks: Perspective, Front, Top, and Side. You can add
several additional bookmarks to a camera using the Bookmark Editor.
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To save a camera’s view:
1

In the camera’s view, select View > Bookmarks > Edit Bookmarks.
The Bookmark Editor appears.

2

To create a bookmark with a custom name, type the name of the bookmark
in the Name field and click the Apply button.
To create a bookmark with a system-assigned name, click the New
Bookmark button.

3

Click the Close button.
To load a camera’s view:
In the camera’s view, select the bookmark from the View > Bookmarks menu
or from the View > Predefined Bookmarks menu.
To rename a saved (bookmarked) camera view:

1

In the camera’s view, select View > Bookmarks > Edit Bookmarks.
The Bookmark Editor appears.

2

Select the bookmark you want to rename.

3

Type the new name for the bookmark in the Name field and press Enter.

4

Click the Close button.
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To delete a saved (bookmarked) camera view:
1

In the camera’s view, select View > Bookmarks > Edit Bookmarks.
The Bookmark Editor appears.

2

Select the bookmark you want to delete.

3

Click the Delete button.

4

Click the Close button.

Making camera views render faster
Rendering a scene often takes a long time. You can, however, make camera
views render faster by not selectively focusing the camera, or by selectively
focusing the camera so that more objects are in focus.
To make camera views render faster:
Turn off Depth Of Field, or increase the F Stop (see “Selectively focusing a
camera’s view” on page 185).
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