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In this section
Introduction    1
PortfolioWall components    1
Installation summary    2
System requirements    2

Introduction
Welcome to PortfolioWall 1.5. This document explains how to 
install, license, start, and set up PortfolioWall.

Note Procedures are written for Windows NT and may be 
slightly different on Windows 2000 Professional.

PortfolioWall components
A PortfolioWall installation can consist of the following 
components and third party applications:

� PortfolioWall application (page 8)

� PortfolioWall Viewer (page 11)

� PortfolioWall Web Client (page 14)

� Apache Web Server (page 14)

� PortfolioWall client components (page 17)

� Netscape Communicator (page 19)

� Sample data (page 21)

� QuickTime (page 23)

� Shockwave Player (page 25)

� Sentinel dongle driver (page 26)

� HTML Help Viewer (page 28).
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Installation summary
To install PortfolioWall you must do the following:

1 Verify that the system you want to install PortfolioWall on 
meets the minimum requirements (page 2).

2 Start the PortfolioWall CD navigator (page 7) and follow 
the instructions to install the various PortfolioWall 
components.

3 Obtain and install a PortfolioWall license (page 31).

4 Start PortfolioWall to verify that it is installed correctly 
and set it up (page 39).

System requirements
Your system must meet the following requirements in order to 
install and/or run the various PortfolioWall components. 
Make sure your system meets these requirements before 
installing PortfolioWall. Certain qualified systems are listed at 
the end of this section.

Note In order to install any PortfolioWall component, your 
system drive (usually C:) must have a certain amount 
of space available equal to the size of the installed 
component. For example, if you are installing the 
PortfolioWall application on your D: drive, your D: 
drive must have 30 MB of available disk space and 
your C: drive must have 30 MB of available disk space 
for the installer to temporary store files during 
installation.

PortfolioWall application requirements

� A computer running Microsoft Windows NT 4.0 with 
Service Pack 5 or higher, or Windows 2000 Professional.

� At least 30 MB of available disk space (with at least 3 MB 
of available disk space on your system drive).

� At least 256MB of RAM.
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� An Ethernet ID or hard disk ID (for licensing).

� Internet Explorer 3.0 or higher to view the online help.

PortfolioWall Viewer requirements

� A computer running Microsoft Windows NT 4.0 with 
Service Pack 5 or higher, or Windows 2000 Professional.

� At least 40 MB of available disk space.

� At least 256MB of RAM.

� An Ethernet ID or hard disk ID (for licensing).

PortfolioWall Web Client requirements

Server requirements

� A computer running Microsoft Windows NT 4.0 with 
Service Pack 5 or higher, or Windows 2000 Professional.

� At least 5 MB of available disk space.

� At least 256MB of RAM.

� An Ethernet ID or hard disk ID (for licensing).

Client requirements

� A computer that can run Netscape Navigator 4.5 or 
higher.

Note The PortfolioWall Web Client is not compatible with 
Netscape 6.0.

PortfolioWall sample data requirements

� At least 187 MB of available disk space.
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Qualified systems

The following systems are qualified to run the PortfolioWall 
application. For the most up-to-date list of qualified systems, 
see the PortfolioWall section of the Alias Wavefront web site: 
http://www.aliaswavefront.com/portfoliowall.
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Company Model CPU
Graphics 
Controller

Driver Version Web OS

Compaq® Professional 
Workstation 
6000

Pentium 
II

Elsa Gloria XL (Elsa) www.compaq.com 
www.elsa.com

NT

Compaq Professional 
Workstation 
6000

Pentium 
II

Diamond Fire GL 4000 
(Diamond 
Multimedia)

4.00.1381.2221.4.0.
0

www.compaq.com 
www.diamondmm.
com

NT

Compaq AP 500 Pentium 
II

Oxygen GMX2000 
(3Dlabs)

www.compaq.com 
www.3dlabs.com

NT

Compaq SP700 Pentium 
III

Intense 3D Wildcat 
4000 (Intense 3D)

04.06.02.22, 4.0.0 www.compaq.com NT

Compaq SP700 Pentium 
III Xeon

Oxygen GVX1 
(3Dlabs)

2.14-1030, 4.0.0 www.compaq.com NT

Dell® Precision™ 
Workstation 210

Pentium 
II

Permedia2 (3Dlabs) 4.00.1381.0277 www.dell.com 
www.3dlabs.com 
www.diamondmm.
com

NT

Dell Precision 
Workstation 410

Pentium 
II

AccelGalaxy 
(Evans&Sutherland)

3.0,0719,1052 4.0.0 www.dell.com 
www.es.com

NT

Dell Precision 
Workstation 610

Pentium 
II

Intense 3D Pro 3400 
(Intergraph)

04.06.02.22, 4.0.0 www.dell.com NT

Dell Precision 
Workstation 610

Pentium 
II Xeon

Oxygen GMX2000 
(3Dlabs)

2.12-0733, 4.00 www.dell.com 
www.3dlabs.com

NT

Hewlett 
Packard®

HP Kayak XW Pentium 
II

Visualize FX4 (HP) www.hp.com NT

Hewlett 
Packard

HP Kayak 
Visualize X

Pentium 
III

Visualize FX6+ (HP) FX.00.02.04, 4.0.0 www.hp.com NT

Hewlett 
Packard

HP Kayak 
Visualize X

Pentium 
II Xeon

Visualize FX4+ (HP) FX.00.02.04, 4.0.0 www.hp.com NT

Hewlett 
Packard

HP Kayak 
Visualize X

AccelGalaxy 
(Evans&Sutherland)

v3.0GY-B0719 www.hp.com NT

IBM® Intellistation M 
Pro 6889

Intense 3D Pro 3400 
(Intergraph VX 113-
GT)

04.06.02.22, 4.0.0 www.ibm.com NT

IBM Intellistation Z 
Pro

Pentium 
III

Intense 3D Wildcat 
4000 (Intense 3D)

04.06.02.22, 4.0.0 NT

IBM Intellistation M 
Pro 6889

Pentium 
III

Fire GL1                           
(Diamond 
Multimedia)

4.00.1381.1066 www.ibm.com 
www.diamondmm.
com

NT
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Intergraph
®

TDZ 2000 
Graphics 
Workstation

Pentium 
II

RealiZm II ZX13-GT 
RealiZm II ZX25-GT  
RealiZm II VX25-GT  
RealiZm II VX113-GT 
(Intergraph)

www.intergraph.co
m

NT

Intergraph TDZ2000 GX1 Pentium 
II

Intense 3D Wildcat 
4000 (Intense 3D)

04.06.02.22, 4.0.0 www.intergraph.co
m

NT

Silicon 
Graphics®

Visual 
Workstation 320

Pentium 
III

Cobalt™ Graphics 
(Silicon Graphics Inc.)

www.sgi.com NT

Silicon 
Graphics

Visual 
Workstation 540

Cobalt Graphics 
(Silicon Graphics Inc.)

www.sgi.com NT

Company Model CPU
Graphics 
Controller

Driver Version Web OS
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Starting the PortfolioWall CD navigator
Before you can install PortfolioWall, you must start the 
PortfolioWall CD navigator. The navigator allows you to 
install the various PortfolioWall components and third party 
applications required for using PortfolioWall.

To start the PortfolioWall CD navigator

1 Make sure you are logged on with Administrator 
privileges.

2 Close all open applications.

3 Insert the PortfolioWall CD into your CD-ROM drive.

The PortfolioWall CD navigator automatically starts.
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If the navigator does not automatically start, browse the 
top level of the CD and double-click the file Launch.exe.

4 Click Install to display the installation page.

5 To continue installing the PortfolioWall application, go to:

� Installing the PortfolioWall application on page 8

To install another PortfolioWall component, go to any of 
the following sections:

� Installing the PortfolioWall Viewer on page 11

� Installing the PortfolioWall Web Client on page 14

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

Installing the PortfolioWall application
The PortfolioWall application is the main component of 
PortfolioWall. It allows you to view and modify PortfolioWall 
projects on a computer running Windows NT or Windows 
2000 Professional.

Note If you plan to install the PortfolioWall web client, you 
must install the PortfolioWall application on the 
server computer before installing the Apache Web 
Server (page 14).
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Note If you do not have the full installation of QuickTime 5 
or higher already installed on your system, it will be 
installed with the PortfolioWall application.

If you plan to install the PortfolioWall web client 
(page 14), you should install Netscape Navigator 
(page 19) before installing the PortfolioWall 
application. That way, the QuickTime plug-in for 
Netscape Navigator will also be installed when you 
install the PortfolioWall application.

If you install the PortfolioWall application before 
installing Netscape Navigator, the QuickTime plug-in 
for Netscape Navigator will not be installed.

To install the PortfolioWall application

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7).

2 Click Install PortfolioWall to start the InstallShield Wizard.

Note If the PortfolioWall 1.5 application is already installed 
on your system, the Program Maintenance page 
appears. See Modifying, repairing, or removing 
PortfolioWall on page 28.

3 Click Next to display the destination folder to install the 
PortfolioWall files.

Do any of the following:
9
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� To use the default location, click Next.

� To choose a different location, click Change to display 
the Change Current Destination Folder page.

Choose a location and click OK. Then click Next.

The Setup Type page appears.

4 Choose a setup type:

� Complete installs all program features and requires the 
most disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which program features 
to install and where to install them. Only advanced 
users should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Complete install, the Ready to Install the 
Program page appears.

5 Click Install to install the PortfolioWall application.

A status bar indicates the progress of the installation.

Note If you do not have the full installation of QuickTime 5 
or higher already installed on your system, the 
QuickTime Install page appears.

To install QuickTime now, choose Launch the QuickTime 
installer now, click Next, and follow the instructions that 
appear. For more information see Installing QuickTime 
on page 23.

To install QuickTime later, choose Don’t install 
QuickTime now and click Next. For instructions on 
installing QuickTime, see Installing QuickTime on 
page 23.
10
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Note If you do not have the HTML Help viewer already 
installed on your system, the HTML Help Viewer Install 
page appears.

To install the HTML Help viewer now, choose Launch 
the HTML Help Viewer installer now, click Next, and follow 
the instructions that appear. For more information see 
Installing the Help Viewer on page 28.

To install HTML Help viewer later, choose Don’t install 
HTML Help Viewer now and click Next. For instructions 
on installing the HTML Help viewer, see Installing the 
Help Viewer on page 28.

When the PortfolioWall application is installed, the 
InstallShield Wizard Completed page appears.

6 Click Finish to return to the PortfolioWall CD navigator.

7 To continue installing another PortfolioWall component, 
see:

� Installing the PortfolioWall Viewer on page 11

� Installing the PortfolioWall Web Client on page 14

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing the PortfolioWall Viewer
The PortfolioWall Viewer is a separate application that allows 
you to interactively view 3D models in various formats. You 
must install the PortfolioWall Viewer if you want to use 
PortfolioWall to view 3D models.
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To install the PortfolioWall Viewer

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7).

2 Click Install PortfolioWall Viewer to start the InstallShield 
Wizard.

Note If the PortfolioWall Viewer 1.5 is already installed on 
your system, the Program Maintenance page appears. 
See Modifying, repairing, or removing PortfolioWall on 
page 28.

3 Click Next to display the destination folder to install the 
PortfolioWall Viewer files.

Do any of the following:

� To use the default location, click Next.

� To choose a different location, click Change to display 
the Change Current Destination Folder page.

Choose a location and click OK. Then click Next.

The Override File Type Associations page appears.

4 Choose the file types that the PortfolioWall Viewer will 
handle from within PortfolioWall:

� ma (Maya ASCII)

� mb (Maya binary)

� wire (Alias wire file)

� dxf (Data eXchange Format)
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� iges (IGES)

� igs (IGES).

Then click Next.

The Setup Type page appears.

5 Choose a setup type:

� Complete installs all program features and requires the 
most disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which program features 
to install and where to install them. Only advanced 
users should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Complete install, the Ready to Install the 
Program page appears.

6 Click Install to install the PortfolioWall Viewer.

A status bar indicates the progress of the installation.

When the PortfolioWall Viewer is installed, the InstallShield 
Wizard Completed page appears.

7 Click Finish to return to the PortfolioWall CD navigator.

8 To continue installing another PortfolioWall component, 
see:

� Installing the PortfolioWall Web Client on page 14

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.
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Installing the PortfolioWall Web Client
The PortfolioWall Web Client allows you to view and modify 
PortfolioWall projects from a computer using any operating 
system that Netscape Navigator can run on.

The PortfolioWall Web Client consists of the following 
components:

� Apache Web Server installed on a server computer 
running Windows NT or Windows 2000 Professional (see 
Installing the Apache web server on page 14).

� The PortfolioWall client components (including the 
PortfolioWall Server) installed on the server computer 
running Windows NT or Windows 2000 Professional (see 
Installing the PortfolioWall client components on page 17).

� Netscape Communicator 4.5 or higher installed on each 
client computer that you want to use to view or modify 
PortfolioWall projects from (see Installing Netscape 
Communicator on page 19). The PortfolioWall web client is 
not compatible with Netscape Communicator 6.0.

Installing the Apache web server

For more information on the Apache web server, see the 
Apache web site at http://httpd.apache.org.

To install the Apache web server

Note You must install the PortfolioWall application (see 
Installing the PortfolioWall application on page 8) on the 
server computer before installing the Apache web 
server.

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7).

2 Click Install Web Client to display the web client installation 
page.
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3 Click Install Apache Web Server to start the InstallShield 
Wizard.

4 Click Next to display the License Agreement.

Note If the Apache web server 1.3.20 is already installed on 
your system, the Program Maintenance page appears. 
See Modifying, repairing, or removing PortfolioWall on 
page 28.

5 Read the license agreement, then click I accept the terms in 
the license agreement.

6 Click Next to display information about the Apache web 
server.
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7 Read this information, then click Next to display the Server 
Information page.

8 Enter your server’s Network Domain, Server Name, and 
Administrator’s Email Address.

9 Choose to install Apache httpd Server programs and 
shortcuts to:

� Run as a service for All Users. (We recommend using 
this setting, unless you only want to run the server 
occassionally.)

� Run when started manually, only for me.

10 Click Next to display the Setup Type page.

11 Choose a setup type:

� Complete installs all program features and requires the 
most disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which program features 
to install and where to install them. Only advanced 
users should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Complete install, the Destination Folder page 
appears.

12 Choose the destination folder to install the Apache web 
server files:

� To use the default location, click Next.

� To choose a different location, click Change to display 
the Change Current Destination Folder page.

Note Make sure you install the Apache web server on a 
drive that has enough space to store all the images 
created when using the PortfolioWall web client.

Choose a location and click OK. Then click Next.

The Ready to Install the Program page appears.

13 Click Install to install the Apache web server.
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A status bar indicates the progress of the installation.

When the Apache web server is installed, the Installation 
Wizard Completed page appears.

14 Click Finish to return to the PortfolioWall CD navigator.

15 To continue installing another web client component, see:

� Installing the PortfolioWall client components on page 17

� Installing Netscape Communicator on page 19.

To continue installing another PortfolioWall component, 
see:

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing the PortfolioWall client 
components

To install the PortfolioWall client components

Note You must install the Apache web server before 
installing the PortfolioWall client components (see 
Installing the Apache web server on page 14). If you have 
more than one web server installed on your system, 
the PortfolioWall client components will install in the 
first Apache configuration that it finds.

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7) and click Install Web 
Client to display the web client installation page.

2 Click Install Client Components to start the InstallShield 
Wizard.
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Note If the PortfolioWall 1.5 client components are already 
installed on your system, the Program Maintenance 
page appears. See Modifying, repairing, or removing 
PortfolioWall on page 28.

3 Click Next to display the Setup Type page.

4 Choose a setup type:

� Complete installs all program features and requires the 
most disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which program features 
to install and where to install them. Only advanced 
users should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Complete install, the Ready to Install the 
Program page appears.

5 Click Install to install the PortfolioWall client components.

A status bar indicates the progress of the installation.

When the PortfolioWall client components are installed, 
the InstallShield Wizard Completed page appears.
18
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6 Click Finish to return to the PortfolioWall CD navigator.

7 To continue installing another web client component, see:

� Installing Netscape Communicator on page 19.

To continue installing another PortfolioWall component, 
see:

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing Netscape Communicator

Netscape Communicator is a suite of software that includes 
Netscape Navigator.

To install Netscape Communicator on a Windows system

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7) and click Install Web 
Client to display the web client installation page.

2 Click Install Netscape for NT/Win2K to start the InstallShield 
Wizard.
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3 Click Next to display the Software License Agreement page.

4 Read the license agreement, then click Yes to accept the 
terms of the agreement and display the Setup Type 
window.

5 Choose a setup type:

� Typical installs all program features and requires the 
most disk space. We recommend choosing a Typical 
install.

� Custom allows you to choose which program features 
to install and where to install them. Only advanced 
users should choose a Custom install.

6 Choose the destination directory to install the Netscape 
Communicator files:

� To use the default location, click Next.

� To choose a different location, click Browse, choose a 
directory, and click OK. Then click Next.

If you choose a Custom install, the Netscape Options page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Typical install, the Netscape Desktop 
Preference Options page appears.

7 Choose any of the following options:

� Make Netscape Communicator my default Internet 
browser.

� Make Netscape Netcenter my home page.

� Use Netscape Netcenter to search the Web.

Click Next to display the Select Program Folder page.

8 Use the default folder Netscape Communicator, or enter a 
different name for the program folder.

Click Next to display the Start Copying Files page.

9 Click Install to install Netscape Communicator.

A status bar indicates the progress of the installation.

10 When Netscape Communicator is installed, a prompt asks 
if you want to read the README file.
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Click Yes to read the README file. Close the README 
window when you are finished reading it.

Otherwise, click No.

11 The Setup is Complete window appears.

12 Click OK. The Netscape Communicator folder appears.

13 Close the Netscape Communicator folder to return to the 
PortfolioWall CD navigator.

14 To continue installing another PortfolioWall component, 
see:

� Installing the PortfolioWall sample data on page 21

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

To install Netscape Navigator on a non-Windows system

1 Browse the Netscape folder on the PortfolioWall CD.

2 Locate the sub-folder for your operating system and run 
the installer in it.

3 If your operating system is not listed, go to Netscape’s 
home page and download the version of Netscape 
Navigator for your operating system.

http://home.netscape.com

Installing the PortfolioWall sample data
The PortfolioWall CD includes a PortfolioWall project 
containing sample data. You can use this sample data to:

� verify that PortfolioWall can read all necessary file formats

� set the pixel aspect ratio for your display

� learn how to use PortfolioWall.
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To use the sample data, you must install it on your computer.

To install the sample data

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7).

2 Click Install Sample Data to start the InstallShield Wizard.

Note If the PortfolioWall 1.5 sample data is already installed 
on your system, the Program Maintenance page 
appears. See Modifying, repairing, or removing 
PortfolioWall on page 28.

3 Click Next to display the Setup Type page.

4 Choose a setup type:

� Complete installs all sample data and requires the most 
disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which sample data to 
install and where to install them. Only advanced users 
should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.
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If you choose a Complete install, the Ready to Install the 
Program page appears.

5 Click Install to install the PortfolioWall sample data.

A status bar indicates the progress of the installation.

When the PortfolioWall sample data is installed, the 
InstallShield Wizard Completed page appears.

6 Click Finish to return to the PortfolioWall CD navigator.

7 To continue installing another PortfolioWall component, 
see:

� Installing QuickTime on page 23

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing QuickTime
You must have a full installation of QuickTime 5 in order to 
view all supported file types in PortfolioWall.

If you do not have a full installation of QuickTime 5 when you 
install the PortfolioWall application (see Installing the 
PortfolioWall application on page 8), a prompt will ask if you 
want to install it. If you do not install QuickTime when 
installing the PortfolioWall application, you must manually 
install QuickTime.

To install QuickTime

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7) and click Install Other 
Software to display the other software installation page.

2 Click Install QuickTime to start the QuickTime installer.
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3 Click Next to display the Welcome page.

4 Click Next to display the Software License Agreement.

5 Read the license agreement and click Agree to accept it and 
display the Choose Destination Location page.

6 Choose the destination directory to install the QuickTime 
files:

� To use the default location, click Next.

� To choose a different location, click Browse, choose a 
directory, and click OK. Then click Next.

The Choose Installation Type page appears.

7 Choose Recommended and click Next to display the Select 
Program Folder page.

8 Use the default folder QuickTime, or enter a different name 
for the program folder.

Click Next to display the QuickTime Plugin Options page.

9 Choose to install the QuickTime plugin for:

� Netscape Navigator or Communicator

� Microsoft Internet Explorer

Then click Next to display the Enter Registration page.

10 You do not need to enter any registration information. 
Click Next to open the QuickTime Settings window and the 
Introduction page.
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The QuickTime folder appears.

11 Click Next to display the Browser Plug-in page.

12 Click Next to display the File Type Associations page.

13 Click Finish to install QuickTime.

A status bar indicates the progress of the installation.

14 When QuickTime is installed, the Finished page appears.

15 You can choose to read the README file and/or launch 
the QuickTime player.

16 Click Close and close the QuickTime folder to return to the 
PortfolioWall CD navigator.

17 To continue installing another PortfolioWall component, 
see:

� Installing the Shockwave Player on page 25

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing the Shockwave Player
You need to install the Shockwave 8.0 Player to see animated 
examples in the PortfolioWall online help.

To install the Shockwave Player

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7) and click Install Other 
Software to display the other software installation page.

2 Click Install Shockwave Player to start the Shockwave 
installer.
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3 Click Next to display the browsers that the Shockwave 
Player will be installed into.

4 Click Install to install the Shockwave Player.

A status bar indicates the progress of the installation.

When the Shockwave Player is installed, the Shockwave 
installer displays Congratulations! You have successfully 
installed Shockwave Player.

5 Click Finish to return to the PortfolioWall CD navigator.

6 To continue installing another PortfolioWall component, 
see:

� Installing the Sentinel dongle driver on page 26

� Installing the Help Viewer on page 28.

To exit the PortfolioWall CD navigator, click Exit.

Installing the Sentinel dongle driver
The Sentinel dongle driver is required if you are using a 
Sentinel dongle to license PortfolioWall (see License on 
page 31). Most users do not use Sentinel dongles. If you are 
not using a Sentinel dongle, you do not need to install the 
Sentinel dongle driver.

To install the Sentinel dongle driver

1 Start the PortfolioWall CD navigator (see Starting the 
PortfolioWall CD navigator on page 7) and click Install Other 
Software to display the other software installation page.

2 Click Install Sentinel Driver to start the InstallShield Wizard.
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Note If any version of the Sentinel System Driver is already 
installed on your system, the Confirm Upgrade page 
appears. To upgrade to the latest Sentinel driver, click 
Upgrade.

3 Click Next to display the License Agreement page.

4 Read the license agreement, then choose I accept the terms 
in the license agreement to accept it.

5 Click Next to display the Setup Type page.

6 Choose a setup type:

� Complete installs all sample data and requires the most 
disk space. We recommend choosing a Complete 
install.

� Custom allows you to choose which sample data to 
install and where to install them. Only advanced users 
should choose a Custom install.

Then click Next.

If you choose a Custom install, the Custom Setup page 
appears.

Use this page to select which features to install and where 
to install them. Then click Next.

If you choose a Complete install, the Ready to Install the 
Program page appears.

7 Click Install to install the Sentinel driver.
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A status bar indicates the progress of the installation.

When the Sentinel driver is installed, the InstallShield 
Wizard Completed page appears.

8 Click Finish.

The Sentinel System Driver Installer Installation window 
appears, indicating that you must restart your system for 
the configuration changes to take place.

9 Click Yes to restart your system now.

Click No if you plan to restart your system later.

10 To continue installing another PortfolioWall component, 
see:

� Installing the Help Viewer on page 28.

11 To exit the PortfolioWall CD navigator, click Exit.

Installing the Help Viewer
You need to install the Help Viewer to see the PortfolioWall 
online help.

The Help Viewer is automatically installed when you install 
the PortfolioWall application (see Installing the PortfolioWall 
application on page 8), so you do not normally need to install it 
manually.

To install the Help Viewer

1 Browse the HtmlHelp folder on the PortfolioWall CD.

2 Double-click the hhupd.exe file and follow the prompts.

Modifying, repairing, or removing PortfolioWall
If you have any of the following PortfolioWall components 
installed on your computer, you can modify, repair (reinstall), 
or remove them:

� the PortfolioWall application
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� the PortfolioWall Viewer

� the PortfolioWall Web Client

� the Apache Web Server

� the PortfolioWall web components

� the PortfolioWall sample data.

For example, if you have an older version of a component 
installed on your computer, you can remove it. Or if you 
installed PortfolioWall without a certain component, you can 
reinstall PortfolioWall including the missing component.

Tip Another method of modifying, repairing, or removing 
a PortfolioWall 1.5 component is to follow the 
installation instructions for the PortfolioWall 
component (see Starting the PortfolioWall CD navigator 
on page 7) until the Program Maintenance window 
appears (see step 6 below).

To modify, repair, or remove a PortfolioWall component

1 Choose Start > Settings > Control Panel to open the Windows 
Control Panel.

2 Double-click Add/Remove Programs to open the Add/Remove 
Programs Properties window.

3 Select the PortfolioWall component from the list of 
programs:

� PortfolioWall 1.1 (an older version of the PortfolioWall 
application, if installed)

� PortfolioWall 1.5 (the PortfolioWall application)
� PortfolioWall Viewer 1.5

� Apache httpd Server 1.3.20

� PortfolioWall Web Client 1.5 (client components)
� PortfolioWall Sample Data

4 Click Add/Remove to open the InstallShield Wizard for that 
component.

5 Click Next to display the Program Maintenance window.

6 Do one of the following:
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You cannot modify which 
features of the Apache web 
server are installed.

� To change which program features are installed, 
choose Modify, then click Next. Use the Custom Setup 
window to choose the components, then click Next, 
then Install, then Finish.

� To repair installation errors in the program (for 
example, missing or corrupt files, shortcuts, and 
registry entries) by reinstalling all components 
currently installed, choose Repair, then click Next, then 
Install, then Finish.

� To remove the program from your computer, choose 
Remove, then click Next, then Remove, then Finish.

7 You may be prompted to restart your computer. If so, we 
recommend that you restart your computer at the prompt.

If you do not restart your computer at the prompt (for 
example, if you have other programs running that you 
want to close before restarting), you must restart your 
computer later.
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Introduction
After you have installed PortfolioWall, you must obtain and 
install a license that allows you to run it. A license is a text 
string that appears something like the following:

FEATURE PWall sgiawd 1.500 permanent uncounted \ 
3D5F9421C12B HOSTID=00c04f8ef647

For more information on what each part of the license means, 
see Understanding licenses on page 49.

There are two methods of licensing PortfolioWall: local 
licensing and server licensing.

Local licensing

In a local licensing situation, you install the PortfolioWall 
software and license on a single computer. This computer 
must have an Ethernet ID or hard disk ID.

A single user on this computer can then run PortfolioWall.

This type of license is called a node-locked license because it 
allows you to run software on a single specific computer.

If you want to run PortfolioWall on many computers using 
local licensing, you must install the PortfolioWall software and 
a unique license on each computer.
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Server licensing

In a server licensing situation, you install the PortfolioWall 
software on several client computers and install the licenses 
and license server software on a license server computer. The 
license server computer must have an Ethernet ID.

Any computer that has the PortfolioWall software installed on 
it and that can access the license server computer by network, 
can run the PortfolioWall software, provided there are enough 
licenses installed on the license server computer.

For example, if the license server computer has five licenses 
installed on it, then any five client computers can run the 
PortfolioWall software at a given time.

These types of license are called a floating licenses because they 
allow you to run software on any computer.

Obtaining a license
Contact your Alias Wavefront Consulting Services 
representative and request a license.

� If you want to use local licensing, request a node-locked 
license and provide the Ethernet ID or hard disk ID for 
each computer that you want to run PortfolioWall on.

� If you want to use server licensing, request a certain 
number of floating licenses (based on the number of 
computers you want to be able to run PortfolioWall on at 
once) and provide the Ethernet ID for the computer that 
you will be using as a license server.

To determine your Ethernet ID or hard disk ID, see Verifying 
your computer’s host ID on page 54.)

Alias Wavefront will then send you the license(s) by email, fax, 
or postal mail.
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Preparing the computer for licensing
Before you can install a license, you must make sure the 
computer has a FLEXlm directory.

� If you are using local licensing, you must prepare each 
computer that you plan to run PortfolioWall on.

� If you are using server licensing, you must prepare the 
license server computer.

To prepare the computer for licensing

1 Double-click the My Computer icon on your desktop to 
open the My Computer window.

2 Double-click the (C:) drive icon to open the C:\ window.

3 Make sure there is a directory named FLEXlm.

If there is not, choose File > New > Folder, type FLEXlm (the 
fifth letter is a lower case L, not a number 1) and press 
Enter to create a FLEXlm directory.

4 Double-click the FLEXlm directory to open it.

5 Choose View > Options to open the Options window.

Note The following instructions may vary based on the 
version of your FLEXlm interface.

6 Click the View tab.

7 Turn on Show all files.

8 Turn off Hide file extensions for known file types.

9 Click OK.

Installing a license
After you have prepared the computer for licensing, you can 
install the license on it.
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� If you are using local licensing, you must install a unique 
node-locked license on each computer that you plan to 
run PortfolioWall on.

� If you are using server licensing, you must install the 
floating license on the license server computer.

To install a license

1 Do one of the following:

� If you received your license by email, and can access 
the email on the computer you want to install the 
license on, open the email.

� If you received your license by email, and cannot 
access the email on the computer you want to install 
the license on, save the email as a text file named 
license.txt. Then transfer the file to the C:\Temp 
directory on the computer you want to install the 
license on.

� If you received your license by fax or postal mail, 
carefully type the license into a text editor (for 
example, Notepad) and save it as a text file named:
C:\Temp\license.txt

on the computer you want to install the license on. 
Use uppercase and lowercase letters exactly as they 
appear; the license won’t work if you make a typing 
error.

Note If the license originates in an email or other file from a 
UNIX computer, make sure you transfer it to your 
Windows computer in ASCII mode, not binary mode. 
Binary mode will add control characters to the license, 
making it unusable.

Note When working with licenses, use a text editor (for 
example, Notepad), not a word processor (for 
example, Microsoft Word) that might add formatting 
information to the text string making it unusable. If 
you must use a word processor, save the license as a 
text file.

2 Do one of the following to start the A|W License Installer:

� Choose Start > Programs > AliasWavefront > Common 
Utilities > installKey.
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� Run C:\Program Files\Common Files\
AliasWavefront Shared\Licensing\bin\InstallKey.exe (where 
C: is the drive that you installed PortfolioWall on).

3 Do one of the following:

� Carefully type the license below Cut and paste OR type 
Product License(s) here. Use uppercase and lowercase 
letters exactly as they appear; the license won’t work if 
you make a typing error.

� Cut the license from the email and paste it below Cut 
and paste OR type Product License(s) here.

� Type the path to the license.txt file you created in step 1 
below OR, enter the path and filename here, or click the 
Browse button and use the file browser to select the 
license.txt file.

By default the license will be installed in:

� C:\Flexlm\aw.dat for node-locked licenses

� C:\Flexlm\aw_servername.dat (where servername is the 
name of the license server computer) for floating 
licenses.

If your organization cannot use the default filename and 
location for the license, click the Advanced button and 
specify another path and filename for the license.

4 Click Install to install the license.

Note If you have an older license installed on your 
computer, the license installer will convert it to 
comments in the new license file.

5 To confirm that the license was installed correctly, open 
the license file (that is, aw.dat or aw_servername.dat) in a 
text editor (for example, Notepad) and make sure it looks 
identical to the license that you received from Alias 
Wavefront.

Note If you need to relocate a license that uses an Ethernet 
ID, contact your Alias Wavefront Consulting Services 
representative.
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Setting up a license server
If you are using server licensing, then you must set up the 
license server computer and client computers.

Setting up the license server computer

To set up the license server computer

1 Make sure TCP/IP is enabled on the license server 
computer (choose Start > Settings > Control Panel > Network > 
Protocols to check).

2 Use My Computer or Windows Explorer to open the 
Com\bin directory. By default, the directory is at 
C:\Aw\Com\bin (where C: is the drive where PortfolioWall 
is installed).

3 Double-click lmtools.exe to start the LMTOOLS utility.

4 Click Configuration using Services. Your license server 
should be listed in the box below.

Note If you didn’t install the license file in the default 
location, you must specify where it is. Click the 
Configure Services tab, enter the license path beside 
Path to the license file, then click Save Service.

5 Click the Configure Services tab.

6 Turn on Use Services and Start Server at Power Up.

7 Click Save Service.

Do not close the LMTOOLS window. See Stopping and 
starting the license server on page 36.

Stopping and starting the license server

Stopping and starting the license server prevents license 
server errors.

Note You must start (or re-read) the license server each time 
you install a new license or change an existing license 
in order for the change to take effect.
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To stop and start the license server

Note To start LMTOOLS, see To set up the license server 
computer on page 36.

1 In the LMTOOLS window click the Stop/Start/Reread tab.

2 Do one of the following:

� If the license server is already running click ReRead 
License File to restart the license server daemons.

� If the license server isn’t already running, click Start 
Server to start the license server.

3 Click the Server Status tab.

4 Click Perform Status Enquiry to confirm that the license 
server is running.

If the license server is running, the following should 
appear in the LMTOOLS window:
servername: license server UP (MASTER)

where servername is the name of the license server 
computer.

5 Close the LMTOOLS window.

Setting up the client computers

You must set up each client computer to indicate where it can 
find the license file on the license server computer.

To set up a client computer

1 Make sure TCP/IP is enabled on the client computer 
(choose Start > Settings > Control Panel > Network > Protocols 
to check).

2 Choose Start > Run to open the Run window.

3 In the Open field type the following:
notepad C:\FLEXlm\aw_servername.dat

where C: is the drive that you have installed PortfolioWall 
on and servername is the name of the license server 
computer.

Click OK to open the license file in Notepad.
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If you are prompted to create the file, choose Yes.

Note This file is only a pointer to the actual license file 
which is on the server computer.

4 Make sure the following lines exist in the file (in the 
following order):
SERVER servername hostid 7111

USE_SERVER

where servername is the name of the server computer and 
hostid is the hostid (that is, Ethernet ID) of the server 
computer.

If necessary, type the lines in the file. Make sure there is a 
carriage return after the second line.

5 Save the file and close Notepad.
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Set up
In this section
Starting, testing, and setting up the PortfolioWall application    39
Setting up and using the PortfolioWall Web Client    42

Starting, testing, and setting up the PortfolioWall 
application

After you have installed the PortfolioWall application, you 
should start it to make sure it installed correctly, and set it up 
for your display device.

Starting and testing the PortfolioWall 
application

Note PortfolioWall requires a root folder to act as an asset 
repository (see the online help for more information). 
You can use any folder as a root folder (for example, 
the sample data folder), or you can create one using 
PortfolioWall. In order to test PortfolioWall, you must 
install the sample data (see Installing the PortfolioWall 
sample data on page 21).

To start and test the PortfolioWall application

1 Choose Start > Programs > AliasWavefront > PortfolioWall 1.5 > 
PortfolioWall 1.5.

The PortfolioWall startup screen appears.

Note If you receive an error message that indicates a 
licensing problem, see Troubleshooting licensing 
problems on page 50.

Note If the startup screen does not appear, and 
PortfolioWall automatically opens a project, click the 
Open Project button or choose File > Open Project and 
skip to step 3 below.
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2 Click New to create a new project.

3 Click Browse, then navigate to the PortfolioWall Sample 
Data folder, for example:
C:\Program Files\AliasWavefront\PortfolioWall Sample Data

4 Click OK.

A prompt asks if you would like to share the project.

5 Click No.

PortfolioWall starts and displays thumbnails of the sample 
data.

6 Click the FileFormats tab to display its thumbnails.

These images are saved in a variety of formats. Make sure 
each thumbnail is an image. If any of the thumbnails 
appear as one of the default thumbnails (see below), 
contact your Consulting Services representative.

Configuring PortfolioWall for real-world 
scale

Before you can view images at real-world scale, you must first 
determine your display’s dimensions in pixels and in a real-
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world unit of measurement and enter these values in 
PortfolioWall.

To determine your display’s dimensions in pixels

1 From your Windows desktop choose Start > Settings > 
Control Panel to open the Control Panel window.

2 Double-click Display to open the Display Properties window.

3 Click the Settings tab.

4 Under Desktop Area, find the pixel dimensions (for 
example, 1280 by 1024 pixels). The first value listed is the 
number of horizontal pixels; the second value listed is the 
number of vertical pixels.

To determine your display’s dimensions in a real-world 
unit of measurement

Use a ruler or measuring tape to measure the horizontal and 
vertical dimensions of the display area in millimeters, 
centimeters, meters, inches, feet, or yards.

Approximate values for certain display sizes are as follows:

To enter your display’s dimensions (in pixels and in a real-
world unit of measurement) in PortfolioWall

1 Choose Edit > Preferences to open the Preferences window.

2 Click the General tab.

3 Choose Set the pixel dimensions to correct distorted images and 
enable real world scale display.

21” 1280 horizontal pixels = 40 cm

1024 vertical pixels = 29.5 cm

50” 1024 horizontal pixels = 110 cm

768 vertical pixels = 61.5 cm

50” 1376 horizontal pixels = 110 cm

768 vertical pixels = 61.5 cm
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4 To the left of horizontal pixels = and vertical pixels =, enter the 
horizontal and vertical dimensions of your display in 
pixels (see To determine your display’s dimensions in pixels on 
page 41).

5 To the right of horizontal pixels = and vertical pixels =, enter 
the horizontal and vertical dimensions of your display in a 
real-world unit of measurement and select the unit of 
measurement (see To determine your display’s dimensions in a 
real-world unit of measurement on page 41).

6 Click Apply.

7 Click OK.

Using PortfolioWall

For more information on using PortfolioWall, click the sample 
data Movies tab and view the instructional movies, or click the 
Help Topics button

or choose Help > Help Topics and read the PortfolioWall online 
help.

Setting up and using the PortfolioWall Web Client
In order to use the PortfolioWall Web Client to view and 
modify PortfolioWall projects (page 46), you must set up the 
server computer (page 42) and set up each client computer 
(page 45).

Setting up the server computer

The server computer is the computer that you have installed 
the Apache Web Server (page 14) and PortfolioWall client 
components (page 17) on.
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To set up the server computer

1 Make sure you are logged on with Administrator 
privileges.

2 Choose Start > Programs > Apache httpd Server > Configure 
Apache Server > Edit the apache httpd.conf Configuration File to 
open the httpd.conf file in Notepad.

3 Remove the # from the beginning of the following two 
lines:
#LoadModule expires_module modules/
mod_expires.so

#LoadModule headers_module modules/
mod_headers.so

4 Search for the following lines:
# UserDir: The name of the directory which is 
appended onto a user’s home

# directory if a ~user request is received.

and immediately above them add the following lines:
<Directory "C:/Program Files/Apache

Group/Apache/htdocs/PortfolioWall/pwMedia">

    <FilesMatch "\.jpg$">

        Header append Pragma "no-cache"

        ExpiresActive on

        ExpiresDefault A0

    </FilesMatch>

</Directory>

Note C: is the default drive for installing the Apache web 
server (page 14). If you installed the Apache web 
server on another drive, you must enter the correct 
drive and path instead of the one listed above.

5 Change the following line:
UseCanonicalName On

to:
UseCanonicalName Off

6 Choose File > Save to save the httpd.conf file.

7 Close Notepad.

8 Choose Start > Settings > Control Panel to open the Control 
Panel.
43
Set up

Setting up and using the PortfolioWall Web Client



9 Double-click Services to open the Services window.

10 Under Service click Apache to select it.

The Status of Apache should read Started indicating that it 
is running.

11 Click Stop to stop the Apache Web Server.

12 A prompt asks Are you sure you want to stop the Apache 
service? Click Yes.

13 Click Startup to open the Service window.

14 Make sure Startup Type is Automatic.

15 Under Log On As select This Account and enter your system 
administrator domain and account ID beside This Account.
domain\account

16 Enter your login password beside Password and Confirm 
Password.

17 Click OK.

18 Click Start to start the Apache Web Server.

Note If the Apache Web Server does not start, see 
Troubleshooting the server computer on page 45.

19 Click Close to close the Services window.

20 Close the Control Panel.

21 Double-click the PortfolioWall 1.5 Server icon on your 
desktop, or choose Start > Programs > AliasWavefront > 
PortfolioWall 1.5 > PortfolioWall 1.5 Server, to start the 
PortfolioWall Server.

22 Make sure TCP/IP is enabled on the server computer 
(choose Start > Settings > Control Panel > Network > Protocols 
to check).

For information on additional settings for the Apache Web 
Server, see Optional settings for the Apache Web Server on 
page 58.
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Troubleshooting the server computer

If the Apache Web Server does not start (see step 18 above), 
you may need to specify the server host name (see below). 
Otherwise, see www.apache.org/docs for more 
troubleshooting information.

To specify the server host name

1 Choose Start > Programs > Command Prompt to open a 
Command Prompt window.

2 Type nslookup localhost and press Enter to display the 
server host name.

3 Choose Start > Programs > Apache httpd Server > Configure 
Apache Server > Edit the apache httpd.conf Configuration File to 
open the httpd.conf file in Notepad.

4 Search for ServerName and replace new.host.name with 
your server host name.

5 Choose File > Save to save the httpd.conf file.

6 Close Notepad.

7 Close the Command Prompt window.

Setting up the client computers

A client computer can be any computer that you have installed 
Netscape Communicator (or Netscape Navigator) 4.5 (or 
higher) on (page 19) and that has access to the server 
computer.

To set up the client computers

1 Start Netscape Communicator or Netscape Navigator.

2 Choose Edit > Preferences to open the Preferences window.

3 Under Category click Advanced.

4 Make sure Enable Javascript is turned on.
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5 Under Category click the + beside Advanced to expand its 
sub-categories.

6 Click Cache to select it.

7 We recommend setting Memory Cache to 10000K to 
optimize the performance of the PortfolioWall Web Client.

8 Click Clear Memory Cache and Clear Disk Cache.

9 Under Category click the + beside Navigator to expand its 
sub-categories.

10 Click Applications to select it.

11 Make sure all of the file types and extensions you plan to 
view are set up with an associated application in 
Netscape. Otherwise some file types may not display 
properly in Netscape. For assistance associating file types 
and applications in Netscape, contact your Consulting 
Services representative.

12 Click OK to close the Preferences window.

Using the PortfolioWall Web Client

To use the PortfolioWall Web Client

1 On the server computer, choose Start > Programs > 
AliasWavefront > PortfolioWall 1.5 > PortfolioWall 1.5 Server to 
start the PortfolioWall Server.

2 In PortfolioWall Server open the project that you want 
clients to be able to view or modify.

For example, open the sample data project that you 
created to test the PortfolioWall application (see Starting 
and testing the PortfolioWall application on page 39).

When you open a project in PortfolioWall Server, it saves 
all of the project’s images in JPEG format in the following 
default directory:
C:\Program Files\Apache 
Group\Apache\htdocs\PortfolioWall\pwMedia

where C: is the drive that you installed the Apache web 
server on.
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Make sure this drive has enough space to store all of these 
images.

Note Avoid removing or organizing asset files using the 
Windows file management tools. Asset files removed 
in this manner are not acknowledged by the 
PortfolioWall Server and will not be automatically 
removed from the pwMedia directory.

3 On a client computer, in Netscape Communicator type the 
name of the server computer followed by /PortfolioWall in 
the Netsite/Location/Go to field (for example, http://
servername/PortfolioWall) and press Enter.

Note If you do not know the name of the server computer, 
choose Start > Programs > Command Prompt, type 
nslookup and press Enter. Type the IP address of the 
server computer and press Enter to display the server 
computer name.

If you do not know the IP address of the server 
computer, on the server computer choose Start > 
Settings > Control Panel > Network > Protocols and 
double-click TCP/IP Protocol.

The PortfolioWall Web Client starts within Netscape 
Communicator.

4 Click Select a project and choose a project from the list.
47
Set up

Setting up and using the PortfolioWall Web Client



The project should appear in the PortfolioWall Web Client.

5 For more information on using the PortfolioWall Web 
Client, click the Help button

and read the PortfolioWall Web Client online help.
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About licenses
After you have installed PortfolioWall, you must obtain and 
install a license that allows you to run it (see License on 
page 31).

Understanding licenses

Alias Wavefront uses a customized version of the FLEXlm 
technology as part of our license management system.

A license is a text string that appears something like the 
following:

FEATURE PWall sgiawd 1.500 permanent uncounted \ 
3D5F9421C12B HOSTID=00c04f8ef647

Host ID

The host ID for the computer: an Ethernet ID (for example, 
00c04f8ef647) or hard disk ID (for example, 7ce051c).

Feature

The PortfolioWall product package you purchased (for 
example, PWall).

License Version

The version number of the PortfolioWall product (for 
example, 1.500).

Expiration

The date on which the license expires (if the license is a 
product evaluation license) or Permanent (if the license is 
a permanent license and there is no expiration date).
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Key

An encrypted string that prevents copyright infringement 
(for example, 3D5F9421C12B).

When working with licenses, use a text editor (for example, 
Notepad), not a word processor (for example, Microsoft Word) 
that might add formatting information to the text string 
making it unusable. If you must use a word processor, save the 
license as a text file.

Troubleshooting licensing problems

If you start the PortfolioWall application and receive an error 
message indicating a licensing problem, use the following 
steps to help troubleshoot the problem.

To troubleshoot a licensing problem

1 Use My Computer or Windows Explorer to verify that the 
C:\FLEXlm directory contains one of the following files:

� C:\Flexlm\aw.dat for node-locked licenses

� C:\Flexlm\aw_servername.dat (where servername is the 
name of the license server computer) for floating 
licenses.

If this file doesn’t exist, then you didn’t complete all the 
necessary steps (see Installing a license on page 33).

2 If you are using server licensing, make sure the date on the 
license server and client computers are synchronized. If 
there is more than 30 minutes difference between them, 
the client may not be able to get a license.

3 Review the licensing procedure to make sure you 
completed all the necessary steps (see License on page 31).

4 See Creating and examining a licensing log file on page 51.

5 See Verifying your computer’s host ID on page 54.

6 If you are using server licensing, try the following:

� Stop and start the license server (see Stopping and 
starting the license server on page 36).

� Restart the license server computer.
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� See Viewing a floating license status report on page 55.

7 If you still cannot resolve the problem, contact your 
Consulting Services representative.

Creating and examining a licensing log file

One way to troubleshoot a licensing problem is to create a 
licensing log file. A licensing log file contains error messages 
which you can use to find possible solutions.

To create and examine a licensing log file

Note If you are using local licensing, create the licensing log 
file on the computer that you are having a licensing 
problem. If you are using server licensing, create the 
licensing log file on the license server computer.

1 Choose Start > Programs > Command Prompt to open a 
Command Prompt window.

2 Type:
set FLEXLM_DIAGNOSTICS=2

and press Enter.

3 Type:
C:\Program 
Files\AliasWavefront\PortfolioWall1.5\
Program\pwPortfolio.exe

(where C: is the drive where PortfolioWall is installed) 
and press Enter.

This command attempts to start PortfolioWall and creates 
a licensing log file.

4 Type:
dir /p

and press Enter to list the files in the directory one page at 
a time.

The licensing log file is named flexnumber.log, where 
number is the process identification number identified by 
the operating system. If more than one flexnumber.log 
file is present, choose the file with the latest time stamp.

5 Type:
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notepad flexnumber.log

and press Enter to open the licensing log file in Notepad.

The log file contains a report for each license failure for all 
PortfolioWall products, so it can be quite long. For each 
product (whether it is available to you or not), an error 
message is logged as follows:
FLEXlm checkout error:

6 In the log file find the error message associated with the 
feature you are troubleshooting and use the following 
table to find a possible solution. (Ignore other information 
in the log file.)

This table contains the most common error messages. If 
multiple errors exist, only the first one is listed in the 
licensing log file. In the following table, the term license file 
refers either to the aw.dat file (for local licensing) or the 
aw_servername.dat file (for server licensing).

Log file error Possible solutions

FLEXLM checkout error: 
Invalid (inconsistent) 
license key. The 
license key and data 
for the feature do not 
match. This usually 
happens when a license 
file has been altered.

• Check the license file for a spelling error in the key, 
expiration, or license version. 

• If it is a floating license, check to see if the server name 
and its host ID are entered correctly.

FLEXLM checkout error: 
Feature has expired...

• Either the current machine date is later than the expiration 
date or there’s a typing mistake in the expiration date. 

FLEXLM checkout error: 
Invalid License File 
syntax.

• Check the entire license file for a typing mistake.

FLEXLM checkout error: 
No such feature exists.

• Check the license file’s spelling of feature names. 
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FLEXLM checkout error: 
Invalid date format in 
license file

• Check the license file’s expiration date for an incorrect 
format, for example, may-4-2002. The correct format is 4-
may-2002. 

• The key may have invalid characters. All characters 
should be in hexadecimal format (numbers or letters A 
through F).

• The license count digit may be absent. It should be 
“uncounted” for a node-locked license or greater than 0 
for a floating license.

FLEXLM checkout error: 
Future license file 
format or misspelling 
in license file. 

• Check the license file’s spelling of any part of the string 
HOSTID number. 

• Make sure that lines ending in “\” are not incorrectly 
using “/” instead.

FLEXLM checkout error: 
No SERVER lines in 
license file. 

• For a node-locked license, check that the license file’s 
license count is “uncounted”.

FLEXLM checkout error: 
license in file appears 
to be corrupted. 

• Check the entire license file for a typing mistake.

FLEXLM checkout error: 
The hostid of this 
system does not match 
the hostid specified in 
the license file. 

• Check that the license file’s Flex ID / host ID and the 
machine’s actual Flex ID / host ID correspond. See 
Verifying your computer’s host ID on page 54 for details.

FLEXLM checkout error: 
License server does not 
support this feature.

• Check the license file to see whether the feature has 
expired, the license server has not yet started, or the 
version number is incorrect. 

• Make sure the USE_SERVER lines on the client machine 
are in the right order.

FLEXLM checkout error: 
Invalid host.

• See Verifying your computer’s host ID on page 54. Click the 
System Settings tab and check that the server name 
matches the contents of Computer/Hostname.

FLEXLM checkout error: 
No server for this 
feature.

• Check that sgiawd is spelled correctly in the DAEMON 
line (VENDOR line for hardware locks).

FLEXLM checkout error: 
License server does not 
support this feature.

• Check the license file to see whether the feature has 
expired, the license server has not yet started, or the 
version is wrong.

• Make sure the USE_SERVER lines are in the right order.
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If the error message isn’t listed in the table above, contact 
your Consulting Services representative.

7 Exit Notepad.

8 If you no longer need the licensing log file, type (in the 
Command Prompt window):
del flexnumber.log

(where number is the number of the file) and press Enter 
to delete it.

9 Close the Command Prompt window.

Verifying your computer’s host ID

Licensing sometimes fails because the licensing software is 
using the wrong Flex ID/host ID. To make sure your licensing 
software is using the correct ID, you can use the lmtools 
utility.

To verify your computer’s host ID

1 Use My Computer or Windows Explorer to open the 
Com\bin directory. By default, the directory is at 
C:\Aw\Com\bin (where C: is the drive where PortfolioWall 
is installed).

2 Double-click lmtools.exe to start the LMTOOLS utility.

3 Click Configuration using Services. Your license server 
should be listed in the box below.

FLEXLM checkout error: 
Cannot connect to 
license server.

• Check that the server is started.
• Check that the SERVER servername line reflects the name 

of the server.
• Check that everything is spelled correctly in the 

DAEMON line (VENDOR line for hardware locks).
• Check that the sgiawd path is right. The default should be 

C:\aw\COM\etc\sgiawd.exe (where C: is the drive 
where PortfolioWall is installed).

FLEXLM checkout error: 
Clock difference too 
large between client 
and server.

• Make sure the time and date on the client and server are 
correct and synchronized. If the time and date of the client 
differs from the server by more than a half hour, the client 
might not be able to get a license.
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Note If you didn’t install the license file in the default 
location, you must specify where it is. Click the 
Configure Services tab, enter the license path beside 
Path to the license file, then click Save Service.

4 Click the System Settings tab to list the host IDs used by 
your computer.

5 Open the license file in Notepad. The default location for 
the license file is:

� C:\FLEXlm\aw.dat for local licensing

� C:\FLEXlm\aw_servername.dat for server licensing

where C: is the drive where PortfolioWall is installed.

If the value in the System Settings doesn’t match the value 
in the aw.dat or aw_servername.dat file, either:

� You typed in the wrong ID in the aw.dat or 
aw_servername.dat file (see Installing a license on 
page 33). Use Notepad to correct the ID in the aw.dat 
or aw_servername.dat file.

� You were supplied with the wrong license 
information. Contact your Consulting Services 
representative.

Viewing a floating license status report

If you are having problems with server licensing (that is, 
floating licenses), you can view a status report to help 
troubleshoot the problem.

For the security 
type...

The value in 
LMTools System 
Settings beside...

Should match the 
license file 
HOSTID and look 
something like...

Ethernet ID Ethernet Address 00c04f8ef647

Hard disk ID Disk Volume Serial 
Number

7ce051c
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To view a floating license status report

1 Use My Computer or Windows Explorer to open the 
Com\bin directory. By default, the directory is at 
C:\Aw\Com\bin (where C: is the drive where PortfolioWall 
is installed).

2 Double-click lmtools.exe to start the LMTOOLS utility.

3 Click Configuration using Services. Your license server 
should be listed in the box below.

Note If you didn’t install the license file in the default 
location, you must specify where it is. Click the 
Configure Services tab, enter the license path beside 
Path to the license file, then click Save Service.

4 Click the Server Status tab.

5 Choose Display Everything.

6 Click Perform Status Enquiry to display a list of status 
information showing:

� if the license server is up and running

� if each feature line in aw_servername.dat is free of 
errors

� if the license count is correct for each feature

Examine the following entries during the following steps:
License server status: 7111@servername

License file(s) on servername: 
C:\FLEXlm\aw_servername.dat:

servername: license server UP (MASTER) v7.0\

Vendor daemon status (on servername):

sgiawd: UP v7.0

(where servername is the name of the license server 
computer). 

7 In the top line, the number 7111 is a fixed value for the 
TCP port used internally by the licensing software.

If you see a different number, make sure that you intend 
for that port number to be used. Otherwise, open the file 
aw_servername.dat and change the number to 7111.
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8 In the next line, check that the correct path to the license 
file is listed.

Note If you didn’t install the license files in the default 
location, make sure the path is correct.

9 The next line of the status information shows that the 
license server is running. If it isn’t, you’ll see an error 
message that begins like this: 
lmgrd not running: Cannot connect to license 
server.
The server (lmgrd) has not been started yet, or 
the wrong port@host or license file is being 
used, or the port or hostname in the license 
file has been changed...

Make sure you have a valid license file with the correct 
name.

Keep handy the aw_servername.dat file, the Status 
information, and any log file error messages you 
examined previously. Contact your Consulting Services 
representative and provide this information.

10 Below the status information is a list of features in the 
aw_servername.dat file and whether the clients can use the 
features.

An example follows:
Feature usage info:
Users of Studiof: (Total of 3 licenses 
available)
Users of AutoStudiof: (Total of 3 licenses 
available)

This example indicates that six licenses are available: three 
for Studio (floating) and three for AutoStudio (also 
floating).

If aw.dat or aw_servername.dat has a typing error, you’ll see 
a message similar to this:
Feature usage info:
Users of Studiof: (Error: 1 licenses, 
unsupported by licensed server)
Users of AutoStudiof: Total of 1 licenses 
available)

Check aw.dat or aw_servername.dat for a typing error in the 
Studiof FEATURE line.
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11 If the preceding procedure doesn’t fix the problem, contact 
your Consulting Services representative and keep the 
information from the preceding two steps nearby.

Optional settings for the Apache Web Server
There are many optional settings for the Apache Web Server. 
Some of the more common ones include changing the 
administrator ’s email address (page 58) and restricting access 
to domains or users (page 58). For information on other 
settings, see http://httpd.apache.org.

Changing the administrator’s email 
address

When installing the Apache Web Server (page 14), you can 
enter the Administrator’s Email Address (step 8). You can also 
change this setting after installing the Apache Web Server.

To change the administrator’s email address

1 Choose Start > Programs > Apache httpd Server > Configure 
Apache Server > Edit the apache httpd.conf Configuration File to 
open the httpd.conf file in Notepad.

2 Search for ServerAdmin and replace the email address (for 
example, you@your.address) with the email address of your 
system administrator or primary contact person.

3 Choose File > Save to save the httpd.conf file.

4 Close Notepad.

Restricting access

By default the Apache Web Server allows all users access to 
the document root (the htdocs directory). You can set up the 
Apache Web Server to restrict access to specific domains, 
subdomains, or computers (page 59), or to specific users 
(page 59).
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Note If you change the document root by editing the 
httpd.conf file, you must re-install the PortfolioWall 
client components and direct them to the new root 
(see Installing the PortfolioWall client components on 
page 17).

To restrict access to specific domains, subdomains, or 
computers

1 Choose Start > Programs > Apache httpd Server > Configure 
Apache Server > Edit the apache httpd.conf Configuration File to 
open the httpd.conf file in Notepad.

2 Search for the following lines:
# Controls who can get stuff from this server.

#

    Order allow,deny

    Allow from all

3 Replace Allow from All with domain or computer specific 
information, for example:
# Controls who can get stuff from this server.

#

    Order allow,deny

    Allow from .tor.aw.sgi.com

4 Choose File > Save to save the httpd.conf file.

5 Close Notepad.

To restrict access to specific users

1 Choose Start > Programs > Command Prompt to open a 
Command Prompt window.

2 Go to the Apache Group\Apache\bin directory.

3 Type the following:
htpasswd -cb filename user password

where filename is the name of a file that the htpasswd 
command will create containing the name (user) and 
password (password) of the first user that you want to 
give access to.

This file is referred to as the AuthUserFile.
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4 To give access to additional users, type:
htpasswd -b filename user password

for each user, using the same filename, but different 
user and password.

This will add them to the AuthUserFile.

5 Choose Start > Programs > Apache httpd Server > Configure 
Apache Server > Edit the apache httpd.conf Configuration File to 
open the httpd.conf file in Notepad.

6 Add the following lines immediately after the Allow 
directive:
AuthName “PortfolioWall”

AuthType Basic

AuthUserFile “C:\Program 
Files\Apache\Group\Apache\bin\filename”

require valid-user

where filename is the filename you entered in step 3.

7 Choose File > Save to save the httpd.conf file.

8 Close Notepad.
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