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Introduction
This tutorial teaches you how to use StudioPaint to paint a
Maya model. You will learn how to:
●

paint a model’s color, bump, and specular textures

●

create and paint a custom texture channel.

Before beginning this tutorial you should already be familiar
with using StudioPaint for painting in 2D (page 37). You
should also be familiar with using Maya for creating materials
and for rendering.
In order to complete this tutorial you will require the a Maya
scene file and a StudioPaint canvas file from the StudioPaint
9.0 CD.
The entire tutorial takes approximately 2.5 hours to complete.
However, the tutorial is divided into sections, so you can stop
after completing each section, and continue at a later time.
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Getting started in Maya
Create a Maya project
1

Open Maya.

2

Choose File > Project > New.
The New Project window is displayed.

3

Type learningStudioPaint in the Name field.

4

Click Use Defaults to use the Maya default directory
structure.

5

Click Accept.

6

Choose Options > Save Preferences.
This updates the preference file with the new current
project. (StudioPaint uses this file to determine the current
Maya project.)

Load the StudioPaint plug-in for Maya
In order to paint a Maya model in StudioPaint, you must load
the StudioPaint plug-in for Maya.
1

Choose Window > General Editors > Plug-in Manager.
The Plug-in Manager window opens.
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The learningStudioPaint project is created and automatically
becomes the current project.

If you don’t see this plug-in
listed, then you need to
install it (see StudioPaint 9.0
Installation and Release Notes
or page 668).

2

Scroll to the bottom of the window, and search for the
StudioPaintMaya1.5.so plug-in.

3

Check the loaded option. If you want the plug-in to
automatically load each time you start Maya, check the
auto load function.
The menu StudioPaint is displayed in the menu bar.

4

Click Close to close the Plug-in Manager.

Open the Maya scene
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1

Choose File > Open Scene.

2

The Open window is displayed.

3

Insert the StudioPaint 9.0 CD into your CD ROM drive.

4

Change the directory to /CDROM/MayaExamples/scenes.

5

Select the toadUnpainted scene.

6

Click the Open button.
The scene contains a 26 surface NURBS toad that was
modeled and animated in Maya.

Save the Maya scene
Choose File > Save Scene As.

2

The Save As window is displayed.

3

Choose File > Go to Current Project in the Save As window.

4

Double-click the scenes subdirectory in the Save As
window.

5

Type toadUnpainted in the Save As window.

6

Click the Save button.

Tutorial

1

The scene is saved in the learningStudioPaint project.
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Assign shading groups to the Maya model
If you want different materials on different parts of the model,
you must assign shading groups to specific surfaces before
you export the model to StudioPaint. For this model, you will
assign the skinSG shading group to the toad’s body, and the
eyeSG shading group to the toad’s eyes. You will then be able
to paint in any of these shading groups’ texture channels.
1

Select the entire toad model.

2

If the Multilister is not currently open, choose Window >
Multilister.

The Multilister contains the default shading groups and two
additional shading groups: skinSG and eyesSG. The skinSG
shading group uses a Blinn surface material, and the
eyesSG shading group uses a Phong surface material.
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3

Choose the skinSG shading group.

4

Choose Edit > Assign in the Multilister to assign the skinSG
shading group to the entire toad.

5

Pick only the toad’s eyes by clicking on one eye, and Shiftclicking on the other eye.

6

Choose the eyesSG shading group.

7

Choose Edit > Assign in the Multilister to assign the eyesSG
shading group to the toad’s eyes.

Export the Maya model as StudioPaint geometry
In order to load a Maya model into StudioPaint, you must
either:

You can also copy selected
geometry in Maya and paste
it into StudioPaint.

●

import the Maya scene directly into StudioPaint

●

export the entire scene as a StudioPaint geometry file and
then load that file into StudioPaint

●

export selected geometry as a StudioPaint geometry file
and then load that file into StudioPaint

A model will load into StudioPaint significantly faster if you
export it as StudioPaint geometry (either the entire scene or
selected geometry).
For this model you will export the entire scene as StudioPaint
geometry.
1

Choose StudioPaint > Export All as StudioPaint File.
The Create StudioPaint Directories window is displayed.

StudioPaint uses the following directory structure for
Maya projects.
/usr
account
maya
projects
learningStudioPaint
brushes
canvas
colors
imageLayers
shapes
spMask
spPix
spGeometry
spTextures
spTextureScripts
stencil
textureLayers
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If you don’t see this menu,
then you need to load the
plug-in (page 563).

If you want to use StudioPaint with a Maya project that
you created before loading the plug-in, you must add
StudioPaint directories to the Maya project.
When the StudioPaint plug-in is loaded, any new projects
that you create in Maya will automatically have the
StudioPaint directories (if you click the Use Defaults button
in the New Project window).
The reason why this tutorial
had you create a project
before loading the
StudioPaint plug-in was
only to show you how to
create StudioPaint
directories. You should
always make sure you load
the plug-in before you create
a project in Maya.

Earlier in this tutorial you created the project
learningStudioPaint in Maya before loading the StudioPaint
plug-in, so you must now add StudioPaint directories to
this project.
2

Click Create Directories.
The StudioPaint directories are automatically created in
the leaningStudioPaint directory, and the Export window is
displayed.

3

Type toad for the name of the file to export, and click the
Export All button.
After a moment the model is exported.
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Getting started in StudioPaint
Set the current StudioPaint project
1

Choose StudioPaint > Launch StudioPaint to switch to
StudioPaint.

2

Choose File > Projects.
The Project Editor is displayed.

3

Set the 3d Rendering Environment to Maya (if it is not set
already).
This is the program in which you will render the 3D
painting.

4

Click the Change button beside the StudioPaint Current
Project.
The Set Current Project window is displayed.

Tutorial

If you don’t see this menu,
then you need to load the
plug-in (page 563).

Painting a Maya model
569
Getting started in StudioPaint

5

Click the Go To Maya Current button.

6

Click the Set Current button.

7

Double-click the upper left corner of the Project Editor to
close it.

Open a StudioPaint canvas
1

In StudioPaint, choose File > Open Canvas.
The Open Canvas File window is displayed.

2

Type /CDROM/MayaExamples/canvas in the Enter filename:
field and press Enter.

3

Select the toadStart file and click Open.
This canvas contains a layer with 2D images of frogs and
toads. You can use these images as a reference and for
picking colors.
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Save the canvas
Choose File > Save Canvas As.

2

The Save Canvas File window is displayed.

3

Click Go To Current.

4

Double-click the canvas directory.

5

Type toadStart in the Enter filename: field.

6

Click Save.

Tutorial

1

The canvas file is saved in the learningStudioPaint project.
7

Remove the StudioPaint 9.0 CD from your CD ROM drive.
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Import the geometry file into StudioPaint
Before you import the
model, you may want to
select four colors from the
frog and toad images
(page 147) and blend them
in the Blend section of the
Color Editor (page 143). Then
when you paint the model
you can easily pick a range
of colors.
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1

Choose File > Import > 3D Geometry or press Alt+g.
The Open Geometry File window is displayed.

2

Select the toad file, and click the Open button.
After a moment the model imports into a 3D layer.

Painting the color texture
You will begin painting the color texture by painting the entire
toad a solid color. You will then paint patterns on the top,
bottom, and sides of the toad.

Paint the entire toad a solid color
1

Pick a color (for example, a light green) from the Color
Editor.

2

Choose Surfaces > Floodfill Texture.
The entire model is painted with the current color.

See Working with Bezier
shapes on page 109.

Next, you will paint the ridges on the toad’s back. To do this
you will first draw a Bezier curve along one of the ridges, and
then paint along this curve. Then you will paint various
patterns and colors over the entire top of the toad.
1

Choose View > Top.

2

Choose the Snap tool from the Bezier Drawer in the
Toolbox.

3

Click-drag at the end of one of the ridges on the toad’s
back in the direction of the ridge.

4

Click-drag again at another point along the ridge.

5

Continue click-dragging until you have drawn a smooth
curve along the entire ridge.
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Paint the top of the toad

Bezier curve

6

Pick a color (for example, a dark green) from the Color
Editor.

7

Choose the FrogBump brush from the Shelf.

8

Paint along the line you drew. The brush snaps to the line.
Paint along the line until the ridge is well-defined.

9

Choose the Pick Shape tool from the Toolbox, or hold
down p, the momentary hotkey.
The Bezier curve that you drew is automatically picked
because it is the only shape.

10 Select Shapes > Transform > Flip - Vertical Axis.
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11 Drag the transform box surrounding the Bezier curve so
that the line lies over the ridge on the other side of the
toad.
12 Choose the FrogBump brush from the Shelf.
13 Paint along the line you moved. The brush snaps to the
line.
Paint along the line until the ridge is well-defined.
14 Choose the Pick Shape tool from the Toolbox, or hold
down p, the momentary hotkey.
The Bezier curve is automatically picked.
15 Press the Backspace key (or the Delete key).
16 Choose the FrogBump brush from the Shelf.
17 Paint over the entire model to make the toad’s skin color
look uneven or mottled.
Don’t worry if you paint over the toad’s eyes. You will repaint them later.
18 Pick a color (for example, a light green) from the Color
Editor.
19 Choose the Snakeskin brush from the Shelf.

21 Pick a color (for example, a light green) from the Color
Editor.
22 Choose the SkinBump brush from the Shelf.
You may want to resize the SkinBump brush. To
interactively resize a brush, hold down the Ctrl key and
click-drag up or down (page 46).
23 Paint over the model to make the toad’s skin look veiny.
24 Choose Surfaces > Project Paint.
After a moment the paint is projected onto the model.
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20 Paint over the model to make the toad’s skin look bumpy.

Note

You do not always have to choose Surfaces > Project Paint
to project paint onto a surface. If Surfaces > Auto Project is
on, the paint will be automatically projected onto the surface
when you change the view (or when you select a tool from
the 3D Drawer).

Paint the bottom of the toad
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1

Choose View > Bottom.

2

Use the FrogBump brush to paint dark green blotches on
the toad’s legs and around the edges of the toad’s chest.

3

Use the 50 LargeAir tool from the Airbrush Drawer in the
Toolbox to paint the toad’s chest pink.

4

Use the 50 LargeAir tool from the Airbrush Drawer in the
Toolbox to paint the toad’s throat orange.

5

Use the SkinBump brush to paint dark pink veins on the
toad’s chest, but do not paint veins on the toad’s throat.

Paint over the edges on the sides of the toad
Now that you have painted the top and bottom of the toad,
you will paint any areas on the sides of the toad that did not
receive any paint.
1

Choose View > Left.

Tutorial

There are some sharp edges along the sides of the toad.
This is because when you projected the paint from the top
and bottom of the toad, the parts of the toad not facing up
or down did not receive any paint.

2

Use the Airbrush tool and FrogBump brush to paint over the
edges on the sides of the toad.
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3

Choose the Tumble tool from the 3D Drawer in the Toolbox.

4

Tumble the view horizontally and continue painting over
any edges on the sides of the toad.

Paint the toad’s eyes
1

Choose View > Front.

2

Choose the Pick tool from the 3D Drawer in the Toolbox.

3

Click on one of the toad’s eyes and Shift-click on the other
eye to select them.

4

Pick a color (for example, yellow) from the Color Editor.

5

Choose Surfaces > Floodfill Texture.

6

Choose View > Left.

7

Choose the Orient tool from the 3D Drawer in the Toolbox.

8

Click on the center of the toad’s eye.
The model tumbles so that the point you picked is facing
you.

9

Choose View > Fit Selected Geometry.
The toad’s eye fills the window.

10 Use the FrogBump and SkinBump brushes to paint the eye.
11 Pick the color black.
12 Choose the Filled tool from the Ellipse Drawer in the
Toolbox.
13 Ctrl-Shift-click-drag in the center of the toad’s eye and
draw a circle.
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14 Press Enter to apply paint to the circle.

15 Choose the Pick Shape tool from the Toolbox, or hold
down p, the momentary hotkey.
The circle is automatically picked.
16 Press the Backspace key (or the Delete key) to delete the
circle.
17 Re-orient the view and paint the right eye.

The toad model has a surface located inside its throat. Later in
this tutorial, you will make the throat area transparent so that
this inner throat surface will become partially visible. If you
plan on completing the entire tutorial, then you should paint
this inner throat surface. This will make the transparency of
the toad’s throat sac more realistic.
If you do not plan on completing the Painting a custom texture
channel section of this tutorial, then skip to Exporting the color
texture to Maya on page 581.
1

Choose View > Bottom.

2

Choose the Pick tool from the 3D Drawer in the Toolbox.

3

Click on the toad’s chest.

4

Choose Surfaces > Hide Selected. The inner throat surface is
now visible.
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Paint the toad’s inner throat

inner
throat
surface

5

Pick the toad’s inner throat surface.

6

Choose Surfaces > Hide Unselected.

7

Choose View > Fit Selected Geometry.

8

Use the 50 LargeAir tool from the Airbrush Drawer in the
Toolbox to paint the inner throat surface light pink.

9

Use the SkinBump brush to paint dark pink veins on the
toad’s inner throat surface.

10 Choose Surface > Project Paint or press Ctrl+a.
11 Choose Surfaces > Show All Surfaces.
12 Choose View > Front to see the entire toad again.
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Exporting the color texture to Maya
After you have painted the color texture, you can then export
the texture as a texture script. The texture script references all of
the individual textures for each surface that you have painted.
Since you have only painted in one texture channel (color), the
texture script will reference 26 file textures, one for each of the
surfaces on the model. When you import the texture script into
Maya, each of these file textures is automatically mapped to
the appropriate shading group and surface.

Export the color texture from StudioPaint
1

Choose File > Export > Textures or press Alt+t.

Tutorial

The Export Textures window is displayed.

2

Type toad in the Enter filename: field and press the Save
button.
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If this message is not
displayed, then you must
also import the toad texture
script in Maya by selecting
StudioPaint > Import
StudioPaint Textures
(page 548).

StudioPaint displays the message:
Update textures into current Maya scene?
3

Click Yes.
All of the textures that you have painted (color) are
exported and automatically updated in Maya.

4

Choose Windows > Maya to switch to Maya.
The textures that you painted in StudioPaint now appear
on the model.

If the textures do not appear,
press 6 to turn on hardware
texturing.

5

Choose Window > Multilister.
The Multilister is displayed.
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The Textures section of the Multilister now contains 26 file
textures: one for each surface of the model.
6

Save the scene as toadColor.

Continue with the tutorial or stop and continue later
You can now either:
●

continue with the remainder of the tutorial (see Painting
the bump texture on page 585), or

●

stop now and complete the remainder of the tutorial later
(see Exit Maya and StudioPaint below).

Exit Maya and StudioPaint
1

In Maya choose File > Quit.

2

In StudioPaint choose File > Exit.
StudioPaint displays the message:
Do you want to save “toadStart” ?

3

Click the Don’t Save button.

When you are ready to continue with the tutorial, re-start
Maya.
1

Open Maya.

2

Load the StudioPaint plug-in (see Load the StudioPaint
plug-in for Maya on page 563).

3

Open the scene toadColor from the learningStudioPaint
project. Do not open the scene toadStart from the StudioPaint
9.0 CD. (See Open the Maya scene on page 564.)

4

Export the scene as a StudioPaint geometry file named
toad (see Export the Maya model as StudioPaint geometry on
page 567).

Painting a Maya model
583
Exporting the color texture to Maya

Tutorial

Re-starting Maya

Re-starting StudioPaint
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1

Open StudioPaint.

2

Set the current project to learningStudioPaint (see Set the
current StudioPaint project on page 569).

3

Open the canvas toadStart from the learningStudioPaint
project, not from the StudioPaint 9.0 CD (see Open a
StudioPaint canvas on page 570).

4

Import the StudioPaint geometry file named toad (see
Import the geometry file into StudioPaint on page 572).

5

Continue with the remainder of the tutorial (see Painting
the bump texture on page 585).
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Painting the bump texture
The bump channel defines raised or depressed areas on a
surface. Where the bump texture is light, the surface will have
a raised area. Where the bump texture is dark, the surface will
have a depressed area. Where the bump texture is 50% gray,
the surface will have neither raised nor depressed areas.
An easy way to create a bump texture is to copy the color
texture into the bump channel and convert it to grayscale. You
can then paint additional features onto this texture.

Add a bump channel to the Textures menu
The Textures menu in StudioPaint lists all of the texture
channels that are available for you to paint. Initially, only the
color texture channel is listed. You can, however, paint in any
renderable channel of a shading group. To paint in other
channels, you must add them to the Textures menu using the
Edit List. You will now make the bump channel available for
painting.
1

Choose StudioPaint > Launch StudioPaint to switch to
StudioPaint.

2

Choose Textures > Edit List.

Tutorial

The Edit List for textures is displayed.

You use the Edit List to select the texture channels that you
want to paint in StudioPaint. By default, only the color
channel is in the Paintable list. To paint in the bump
channel, you must move it from the Unpaintable list to the
Paintable list.
3

Select the bump texture in the Unpaintable list.
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4

Click the << button to move it to the Paintable list.

5

When you have finished, click the Accept button.

6

Choose the Textures menu.
The bump texture channel is displayed in the Textures
menu, and is automatically selected because it was the last
texture channel that you added.
Since you are now painting in more than one texture
channel, you may want to tear off the Textures menu.
Then you will always be able to see what texture channel
you’re painting in.

7

Choose the Textures menu and highlight the dashed line
just under the menu name.

8

Release the mouse button.
The menu separates into its own window which you can
position anywhere on the screen.

Copy the color texture into the bump channel
1

Choose Surfaces > Select All Surfaces.

2

Choose the Pick tool from the 3D Drawer in the Toolbox.

3

Shift-click on each of the toad’s eyes to unselect them.

4

Choose Textures > color to switch to the color channel.

5

Choose Textures > Copy Texture to copy the color channel.

6

Choose Textures > bump to switch to the bump channel.

7

Choose Textures > Paste Texture to paste the color texture
into the bump channel.

Convert the bump texture to grayscale
1

Choose Surfaces > Extract Textures or press Alt+e.

2

In the Layer Editor choose Show > Texture Canvas.

3

In the Layer Editor choose Layer > Select All.

4

Click the Texture window button in the Button bar.
The Texture window is displayed.
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5

Choose the B&W tool from the HSV Drawer in the Toolbox.

6

Click in the Texture window, and then click the Accept
button in the Button bar or press Enter.

7

In the Texture window select Layer > Delete All to delete all
of the texture layers.
This will delete only the extracted textures in the Texture
window. The textures on the model will not be deleted.

8

Click Yes.

9

Close the Texture window.

Tutorial

StudioPaint displays the message:
Do you wish to delete all layers?

Sharpen the bump texture
To create steeper bumps on the toad’s skin, you will sharpen
the bump texture. However, the bump texture is already
projected onto the model. In order to manipulate paint that is
already projected onto a surface, you must take a snapshot of
the surface using Snapshot to Unprojected. This copies the
projected paint to the unprojected paint plane, where you can
manipulate it as you would any 2D layer (for example, using
smear, clone, or sharpen). When you are finished, simply reproject the paint onto the surface.
1

Choose View > Top.

2

Choose Surfaces > Snapshot to Unprojected.
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3

Choose the Low tool from the Sharpen Drawer in the
Toolbox.

4

Click in the Canvas window, and then click the Accept
button in the Button bar (or press Enter).

Note

If the image preview does not sharpen, click in the canvas
window again.

Remove sharp edges from bump texture
1

Choose View > Left.

The edges along the side of the toad are very sharp. You
can remove these edges by painting over them with the
Airbrush tool.
2

Select the 1 Pixel tool from Pick Color Drawer in the
Toolbox, or press and hold c, the momentary hot key.
The cursor changes to an eye dropper.

3

Click a gray on the bottom half of the toad.
The current color changes to the new color.

4

Choose the 20 MediumAir tool from the Airbrush Drawer in
the Toolbox.

5

Choose Surfaces > Project Paint On Visible Surfaces Only so
that it is off.
This will allow you to simultaneously paint onto surfaces
that face you and surfaces on the opposite side of the
model.

6
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Paint along the sharp edge of the toad until the transition
is smooth.

7

Choose View > Right.
The paint was projected through the model to the other
side.

8

Choose Surfaces > Project Paint On Visible Surfaces Only
again so that it is on.
Now paint will project only to the surfaces facing you.

1

Choose View > Top.

2

Choose the Small Solid tool from the Brush Drawer in the
Toolbox.

3

Choose the color white from the Shelf.
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Paint warts in bump texture

In the bump texture, white
makes bumps and black
makes dents.
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4

Paint some white blotches on the toad’s back and sides to
simulate warts.

5

Choose Surfaces > Project Paint or press Ctrl+a.

Painting the specularColor texture
The specularColor channel defines the color of shiny
highlights on a surface. Where the specular texture is light, the
surface will appear shiny. Where the specular texture is darker,
the surface will appear less shiny. The specular texture can
also affect the hue of shiny highlights on the surface.
An easy way to create a specular texture is to copy the color
texture into the specular channel, and invert and adjust the
colors using the Color Curves tool. You can then paint
additional features onto this texture.

Add a specularColor channel to the Textures menu
●

Add a specularColor channel to the Texture menu the same
way you added a bump channel (page 585).

Copy the color texture into the specularColor channel
●

Copy the color texture into the specularColor channel the
same way you copied the color texture into the bump
channel (page 586).

To make the specularColor texture have a blue-green hue, you
will first invert the texture and then adjust individual color
components using the RGB tool in the Color Curve Drawer.
1

Choose Textures > specularColor to select the specularColor
channel.

2

Choose Surfaces > Select All Surfaces.

3

Choose Surfaces > Extract Textures or press Alt+e.

4

In the Layer Editor choose Show > Texture Canvas.

5

In the Layer Editor choose Layer > Select All.

6

Click the Texture window button in the Button bar.
The Texture window is displayed.

7

Click the - button in the Button bar of the Texture window
to zoom out (until you can see all the textures).
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Invert and adjust the colors of the specularColor texture

8

Choose the RGB tool from the Color Curves drawer of the
Toolbox.

9

Open the Tool Editor.

10 Manipulate the RGB curves to invert the colors and give a
dark, blue-green hue. (The color curves should look
approximately like the curves shown in the left margin.)
11 Click in the Texture window, and then click the Accept
button in the Button bar or press Enter.
You can re-extract these
textures if you need them
later.

12 In the Texture window select Layer > Delete All to delete all
of the texture layers.
StudioPaint displays the message:
Do you wish to delete all layers?
13 Click Yes.
14 Close the Texture window.

Paint the specularColor texture
You will now paint the specularColor texture, adding dark
colors where you want the toad’s skin to be less shiny, and
light colors where you want the toad’s skin to be shinier.
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1

Choose a dark blue or black color from the Color Editor.

2

Choose the Snakeskin or Skinbump brush from the Shelf.

3

Paint areas of the surface that you want to be less shiny.

4

Choose a cream or light blue color from the Color Editor.

5

Paint areas of the surface that you want to be more shiny.

Paint the eyes of the specularColor texture

1

Choose the Pick tool from the 3D Drawer in the Toolbox.

2

Click on one of the toad’s eyes and Shift-click on the other
eye to select them.

3

Choose Surfaces > Extract Textures or press Alt+e.

4

Click the Texture window button in the Button bar.
The Texture window is displayed.

5

Select the Fill Opaque tool from the Flood Fill Drawer in the
Toolbox.

6

Open the Tool Editor.

7

Select Blur Edge so that it is on. This will make the flood fill
have soft edges.
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To make the center of the toad’s eyes very shiny, you will flood
fill them with white, working directly on the extracted texture
maps.

8

Close the Tool Editor.

9

Pick the color white.

10 In the Layer Editor, select the EyeL layer.
The texture that is mapped to the left eye becomes
highlighted in the Texture window.
The circle in the highlighted
texture will be light gray if
you adjusted the RGB curves
as shown on page 592. If you
adjusted the RGB curves
differently, then the circle
will have a different color.

11 Click in the circle of the highlighted texture.
The circle becomes white.
12 In the Layer Editor, select the EyeR layer.
The texture that is mapped to the right eye becomes
highlighted in the Texture window.
13 Click in the circle of the highlighted texture.
The circle becomes white.
14 In the Texture window select Layer > Delete All to delete all
of the texture layers.
StudioPaint displays the message:
Do you wish to delete all layers?
15 Click Yes.
16 Close the Texture window.
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Exporting the bump and specularColor
textures to Maya
After you have painted the bump and specularColor textures,
you can then re-export the texture script. The texture script
now references the texture information for the color channel,
the bump channel, and the specularColor channel. That is, the
texture script references 78 file textures, three for each of the
surfaces on the model. When you export the texture script
from StudioPaint, each of these file textures is automatically
mapped to the appropriate shading group and surface in
Maya.

Export all textures from StudioPaint

If this message is not
displayed, then you must
also import the toad texture
script in Maya by selecting
StudioPaint > Import
StudioPaint Textures
(page 548).

1

Choose File > Export > Re-Export Textures to Last Filename.

StudioPaint displays the message:
Update textures into current Maya scene?
2

Click Yes.
All of the textures that you have painted (color, bump, and
specularColor) are exported (replacing the toad texture
script) and automatically updated in Maya.

3

Choose Windows > Maya to switch to Maya.

4

Choose Window > Multilister.
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If this option is dimmed,
then choose File > Export >
Textures, and save the
texture script as toad,
replacing the current toad
texture script.

The Multilister is displayed.

The Textures section of the Multilister now contains 78 file
textures: three for each surface on the model.
5
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In the Multilister select the skinSG shading group.
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6

In the Multilister choose Window > Hypergraph Highlighted.
The Hypergraph is displayed.
StudioPaint automatically created all of these connections
between file textures and surfaces.

7

Close the Hypergraph.

8

Choose Window > Rendering Editors > Render View.
The Render View window is displayed.

9

In the Render View window, choose Render > Render >
persp.

11 Save the scene as toadSpecular.

Continue with the tutorial or stop and continue later
You can now either:
●

continue with the remainder of the tutorial (see Painting a
custom texture channel on page 599), or

●

stop now and complete the remainder of the tutorial later
(see Exit Maya and StudioPaint below).

Exit Maya and StudioPaint
1

In Maya choose File > Quit.

2

In StudioPaint choose File > Exit.
StudioPaint displays the message:
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10 Close the Render View window.

Do you want to save “toadStart” ?
3

Click the Don’t Save button.

Re-starting Maya
When you are ready to continue with the tutorial, re-start
Maya.
1

Open Maya.

2

Load the StudioPaint plug-in (see Load the StudioPaint
plug-in for Maya on page 563).

3

Open the scene toadSpecular from the learningStudioPaint
project. Do not open the scene toadStart from the StudioPaint
9.0 CD. (See Open the Maya scene on page 564.)

Re-starting StudioPaint

598

1

Open StudioPaint.

2

Set the current project to learningStudioPaint (see Set the
current StudioPaint project on page 569).

3

Continue with the remainder of the tutorial (see Painting a
custom texture channel on page 599).
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Painting a custom texture channel
In the Maya animation of the toad, the toad’s throat sac
expands. Suppose you would like the throat sac to be
transparent, but only when it is expanded. If you simply paint
the transparency channel, the throat sac will always be
transparent. Instead, set up a Blend Colors utility so that you
can animate between a state of no transparency, and a state
where only the throat area is transparent. You can then make
one of the Blend Color utility’s color textures paintable.

Create a paintable texture channel in Maya
1

Drag the Time slider to show the animation, then return
the Time slider to 1.

2

Choose Windows > Multilister.
The Multilister is displayed.

3

In the Multilister, double-click the SkinSG shading group.
The Attribute Editor is displayed.

4

Click the Map button beside the Transparency attribute.
The Create Render Node window is displayed.
Click the Utilities tab.

6

In the Color Utilities section of the Create Render Node
window, click the Blend Colors button.

Tutorial

5
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The Attribute Editor updates to show the blendColors1
attributes.
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7

In the Blend Color Attributes section, set Color1 to black.

8

In the Attribute Editor, click Select.

9

Choose StudioPaint > Make Nodes SP Paintable.
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The Make Nodes SP Paintable window is displayed.

All texture channels for the Blend Colors utility are listed.
10 Click on the color2 texture channel.

Tutorial

11 Click Make SP Paintable.
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A Triple Shading Switch
allows you to use a single
shading group to map
different file textures to
different surfaces.

12 A Triple Shading Switch is automatically created and
selected.

13 Open the Extra Attributes section of the Attribute Editor.
You can change the Sp
Channel Name. In this
tutorial, however, you will
leave the name as color2.

Sp Paintable is checked and Sp Channel Name has the name
color2.

14 Click the Close button.
15 Close the Make Nodes SP Paintable window.

Export the Maya model as StudioPaint geometry
●

602

Painting a Maya model
Painting a custom texture channel

Export the model as a StudioPaint geometry file called
toadBlend, the same way you exported the original
scene (page 567).

Import the geometry into StudioPaint
When you import geometry into StudioPaint, you
automatically import all of the textures associated with that
model. If you create a texture in StudioPaint and export it to
Maya, you don’t have to keep the StudioPaint canvas file. If
you want to change a texture, you can simply re-import the
model with its textures.
You will now create a new canvas and import the Maya model
along with all of its textures.
1

Choose StudioPaint > Launch StudioPaint to switch to
StudioPaint.

2

Choose File > New Canvas.
StudioPaint displays the message:
Do you want to save “toadStart”?
Click the Don’t Save button.

4

Choose File > Import > 3D Geometry or press Alt+g.
You should see the toadBlend file that you exported from
Maya.

5

Select the toadBlend file, and click the Open button.
The model imports into a 3D layer.

Add a color2 channel to the Textures menu
1

Choose the Textures menu.
The color, bump, and specularColor texture channels are
displayed in the Textures menu because they were
imported along with the model. The color2 channel was
also imported, but you must add it to the Textures menu.

2

Add the color2 channel to the Textures menu the same way
you added the bump and specularColor channels
(page 585).

Paint the color2 texture
The transparency channel defines how “see-through” a
surface is. Where the transparency texture is white, the surface
Painting a Maya model
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Tutorial

If it isn’t displaying, ensure
that you’re in the
spGeometry directory of the
learningStudioPaint project,
and that you’ve set your
current project (page 569).

3

will be entirely transparent. Where the transparency texture is
black, the surface will be entirely opaque (non-transparent).
Most of the model will have no transparency, so you will paint
it black. Only the throat area needs to be transparent, so you
will paint that area white. You will then blur the entire texture
to ensure a smooth transition between transparent and nontransparent areas.
If selecting View > Bottom
doesn’t show the bottom of
the toad, set Axis Orientation
to Y Up in the 3D Import
Options section of the
Preference Editor (page 415).

1

Choose View > Bottom.

2

Choose the color black from the Shelf.

3

Choose Surfaces > Floodfill Texture.
The entire texture becomes black.
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4

Choose the color white from the Shelf.

5

Use the Airbrush tool to paint a white blotch on the toad’s
throat.

6

Choose the High tool from the Blur Drawer of the Toolbox.

7

Click the Accept button in the Button bar or press Enter.

8

Choose Surfaces > Project Paint.

Painting a Maya model
Painting a custom texture channel

Exporting the custom texture to Maya
Export the color2 texture
The color, bump, and specularColor textures are already
mapped to the appropriate shading groups and surfaces in
Maya. You only need to export the color2 texture.
1

Choose File > Export > Current Texture Channel.
The Export Textures window is displayed.

2

Type toadBlend in the Enter filename: field and press the
Save button.

StudioPaint displays the message:
Update textures into current Maya scene?
3

Click Yes.
Only the color2 texture is exported and automatically
updated in Maya.

4

Choose Windows > Maya to switch to Maya.

5

Choose Window > Attribute Editor.
The Attribute Editor is displayed.

6

In the Attribute Editor, choose Focus > blendColors1.

7

In the Attribute Editor, set Blender to 0.

8

Close the Attribute Editor.

9

Move the time slider to frame 15, where the throat sac is
extended.

10 Tumble the view so that the throat is clearly visible, and
one of the toad’s front legs is hidden behind the throat sac.
This will let you see the effect of the throat sac’s
transparency.
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If this message is not
displayed, then you must
also import the toadBlend
texture script in Maya by
selecting StudioPaint >
Import StudioPaint Textures.

11 Render the scene.

12 Save the scene as toadFinal.
This concludes the Painting a Maya model tutorial. You can now
either:
●

exit Maya and StudioPaint (see Exit Maya and StudioPaint
below), or

●

animate the blendColors1 node (see Animate the custom
texture channel on page 606).

Animate the custom texture channel
You may want to try animating the blendColors1 node using
Maya’s Set Driven Key feature to automatically animate the
Blender value to match the cluster transformation on the
throat.
Using Blend Color Utility nodes and other nodes that would
not normally be paintable, you can easily create effects like
morphing painted textures on multiple surface models. The
possibilities are endless!

Exit Maya and StudioPaint
1

In Maya choose File > Quit.

2

In StudioPaint choose File > Exit.
StudioPaint displays the message:
Do you want to save “toadStart” ?

3
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Click the Don’t Save button.

